超强缠论主图超强波段超强潜伏通达信主图副图选股指标


祝大家投资顺利,一起面对行情 无数次实践证明做波段才是盈利王道  希望大家可以参考。再次提醒,没有完美的指标也没有万能的指标,即便是指标做的再完美也都有出现瑕疵的时候。

指标是辅助,是参考!

指标做的再完美也不如一个消息 

但是,个股犹如四季轮回,有涨有跌,K线是资金走过留下的痕迹,追寻这样的痕迹能不能得到回报?答案是肯定的。有许许多多的高手就是这样不看基本面不看消息面,纯技术手法驰骋股市。


超强缠论主图超强波段超强潜伏通达信主图副图选股指标


主图指标

带了划线 有未来

N:=(1,100,8);


KK:=(0,2,0);


TYP := (HIGH + LOW + CLOSE)/3;


CCI1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,6));


CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));


CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20));


CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));


CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));


CCI:=CCI1+CCI2+CCI3+CCI4+CCI5;


AAAB:=(3*C+H+L+O)/6;


VVAR1:=(8*AAAB+7*REF(AAAB,1)+6*REF(AAAB,2)+5*REF(AAAB,3)+4*REF(AAAB,4)+3*REF(AAAB,5)+2*REF(AAAB,6)+REF(AAAB,8))/36;


VVAR6:=(LLV(VVAR1,2)+LLV(VVAR1,4)+LLV(VVAR1,6))/3;


短线:IF(KK=0, VVAR1, DRAWNULL),COLORWHITE;


中线:IF(KK=0,VVAR6, DRAWNULL),COLORYELLOW;


DRAWBAND(短线,RGB(200,10,10),中线,RGB(10,200,10));


DRAWKLINE(H,O,L,C);


下跌:IF(KK=0 AND VVAR1=VVAR6,VVAR6, DRAWNULL),COLORGREEN;


中:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;


上轨:IF(KK=1,中+3*STD(中,10),DRAWNULL),COLOR000088,LINETHICK1;


IF(KK=1,2*MA(上轨,12)-MA(C,21),DRAWNULL),COLOR666666;


N1:=(1,100,10);


N2:=(1,100,10);


DISP:=(1,3,2);


K:=IF(PERIOD=5,1,{日}


IF(PERIOD=6,1,{周}


IF(PERIOD=7,1,{月}


IF(PERIOD=8,1,{多分钟}


IF(PERIOD=9,1,{多日}


IF(PERIOD=10,1,{季}


IF(PERIOD=11,2,{年}


IF(PERIOD=4,1,{60F}


IF(PERIOD=3,1,{30F}


IF(PERIOD=2,1,{15F}


IF(PERIOD=1,1{5F},1{1F})))))))))))/10;


P1:=PEAK(1,K*N1,1);


P2:=PEAK(1,K*N1,2);


WP1:=PEAKBARS(1,K*N1,1);


WP2:=PEAKBARS(1,K*N1,2);


T1:=TROUGH(2,K*N2,1);


T2:=TROUGH(2,K*N2,2);


WT1:=TROUGHBARS(2,K*N2,1);


WT2:=TROUGHBARS(2,K*N2,2);


TJ1:=P1>T1 AND P2>T2 ;


ZD:=MAX(T1,T2);


ZG:=MIN(P1,P2);


LL:=MIN(T1,T2);


HH:=MAX(P1,P2);


TJ2:=FILTER(ZG>ZD,2);


TJ3:=ZG=REF(ZG,BARSLAST(TJ2)) OR ZD=REF(ZD,BARSLAST(TJ2));


TJ4:=TJ1&&TJ2&&NOT(TJ3);


TJ5:=BETWEEN(ZD,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));


TJ6:=BETWEEN(ZG,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));


TJ7:=ZG>REF(ZG,REF(BARSLAST(TJ4),1))&&ZD<REF(ZD,REF(BARSLAST(TJ4),1));


TJ8:=TJ4&&NOT(TJ5 OR TJ6 OR TJ7);


ZSD:=IF(TJ8,ZD,DRAWNULL);


ZSG:=IF(TJ8,ZG,DRAWNULL);


ZSH:=IF(TJ8,HH,DRAWNULL);


ZSL:=IF(TJ8,LL,DRAWNULL);


STICKLINE(TJ8,ZSH,ZSL,0,-1),COLORMAGENTA;


STICKLINE(TJ8,ZSD,ZSG,IF(DISP=1,3,0),1),COLORMAGENTA;


DRAWTEXT(DISP=2,ZSH,'中枢'),COLORWHITE;


中枢高:PLOYLINE(DISP=2,REF(ZSD,BARSLAST(TJ8))),CIRCLEDOT,COLORLIRED;


中枢低:PLOYLINE(DISP=2,REF(ZSG,BARSLAST(TJ8))),CIRCLEDOT,COLORLIGREEN;


中枢最高:PLOYLINE(DISP=2,REF(ZSH,BARSLAST(TJ8))),POINTDOT,COLORRED;


中枢最低:PLOYLINE(DISP=2,REF(ZSL,BARSLAST(TJ8))),POINTDOT,COLORGREEN;


趋势高:PLOYLINE(DISP=3,ZIG(1,K*N1)),COLORLIBLUE;


趋势低:PLOYLINE(DISP=3,ZIG(2,K*N2)),COLORLIBLUE;


局部低点预选A:=BACKSET(LLV(L,5)<REF(LLV(L,4),1),4);


局部低点预选B:=BACKSET(局部低点预选A=0 AND REF(局部低点预选A,1)=1,2);


局部低点预选C:=IF(局部低点预选B=1 AND REF(局部低点预选B,1)=0,-1,0);


局部高点预选A:=BACKSET(HHV(H,5)>REF(HHV(H,4),1),4);


局部高点预选B:=BACKSET(局部高点预选A=0 AND REF(局部高点预选A,1)=1,2);


局部高点预选C:=IF(局部高点预选B=1 AND REF(局部高点预选B,1)=0,1,0);


缺口判断:=IF(L>REF(H,1),1,IF(H<REF(L,1),-1,0));


距前高天:=BARSLAST(局部高点预选C=1);


距前低天:=BARSLAST(局部低点预选C=-1);


小值周期:=LOWRANGE(L);


大值周期:=TOPRANGE(H);


低保留AA:=IF(局部低点预选C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)<REF(LLV(L,距前高天+1),1),-1,0);


低保留AB:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND (距前高天>=4 OR LLV(缺口判断,距前高天)=-1 OR LLV(L,距前低天+2)<REF(LLV(L,距前低天+1),1)),-1,0);


低保留S:=IF((低保留AA=-1 OR 低保留AB=-1) AND L<REF(H,距前高天+1),-1,0);


预判:=IF((距前低天<4 AND HHV(缺口判断,距前低天)!=1) OR REF(低保留S,距前低天)=0,1,0);


判断:=IF(局部高点预选C=1 AND REF(距前低天,1)<=REF(距前高天,1) AND 预判=1 AND 大值周期>REF(小值周期,距前低天+1) AND 大值周期


>REF(小值周期,距前低天) AND 大值周期>REF(大值周期,距前高天),1,0);


高保留A:=IF(局部高点预选C=1 AND REF(距前低天,1)>REF(距前高天,1) AND HHV(H,距前低天+1)>REF(HHV(H,距前低天+1),1),1,0);


高保留B:=IF(局部高点预选C=1 AND REF(距前低天,1)<=REF(距前高天,1) AND REF(低保留S,距前低天)=-1 AND (距前低天>=4 OR HHV(缺口判断,距前低天)=1),1,0);


高保留:=IF((高保留A=1 OR 高保留B=1 OR 判断=1) AND H>REF(L,距前低天+1),1,0);


预判A:=IF((距前高天<4 AND HHV(缺口判断,距前高天)!=1) OR REF(高保留,距前高天)=0,1,0);


判断A:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND 预判A=1 AND 小值周期>REF(大值周期,距前高天+1) AND 小值周期>REF(大值周期,距前高天) AND 小值周期>REF(小值周期,距前低天),-1,0);


低保留A:=IF(局部低点预选C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)<REF(LLV(L,距前高天+1),1),-1,0);


低保留B:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND (距前高天>=4 OR LLV(缺口判断,距前高天)=-1 OR 判断A=-


1),-1,0);


低保留:=IF((低保留A=-1 OR 低保留B=-1) AND L<REF(H,距前高天+1),-1,0);


距前高天A:=BARSLAST(高保留=1);


距前低天A:=BARSLAST(低保留=-1);


预判X:=IF((距前低天A<4 AND HHV(缺口判断,距前低天A)!=1) OR REF(低保留,距前低天A)=0,1,0);


判断X:=IF(局部高点预选C=1 AND REF(距前低天A,1)<=REF(距前高天A,1) AND 预判X=1 AND 大值周期>REF(小值周期,距前低天A+1) AND 大值周期>REF(小值周期,距前低天A) AND 大值周期>REF(大值周期,距前高天A),1,0);


高保留XA:=IF(局部高点预选C=1 AND REF(距前低天A,1)>REF(距前高天A,1) AND HHV(H,距前低天A+1)>REF(HHV(H,距前低天A+1),1),1,0);


高保留XB:=IF(局部高点预选C=1 AND REF(距前低天A,1)<=REF(距前高天A,1) AND REF(低保留,距前低天A)=-1 AND (距前低天A>=4 OR HHV(缺口判断,距前低天A)=1),1,0);


高保留X:=IF((高保留XA=1 OR 高保留XB=1 OR 判断X=1) AND H>REF(L,距前低天A+1),1,0);


预判XA:=IF((距前高天A<4 AND HHV(缺口判断,距前高天A)!=1) OR REF(高保留XA,距前高天A)=0,1,0);


判断XA:=IF(局部低点预选C=-1 AND REF(距前高天A,1)<=REF(距前低天A,1) AND 预判XA=1 AND 小值周期>REF(大值周期,距前高天A+1) AND 小值周期>REF(大值周期,距前高天A) AND 小值周期>REF(小值周期,距前低天A),-1,0);


低保留XA:=IF(局部低点预选C=-1 AND REF(距前高天A,1)>REF(距前低天A,1) AND LLV(L,距前高天A+1)<REF(LLV(L,距前高天A+1),1),-1,0);


低保留XB:=IF(局部低点预选C=-1 AND REF(距前高天A,1)<=REF(距前低天A,1) AND (距前高天A>=4 OR LLV(缺口判断,距前高天A)=-1 OR 判断XA=-1),-1,0);


低保留X:=IF((低保留XA=-1 OR 低保留XB=-1) AND L<REF(H,距前高天A+1),-1,0);


距前高天YA:=BARSLAST(高保留X=1);


距前低天YA:=BARSLAST(低保留X=-1);


预判YX:=IF((距前低天YA<4 AND HHV(缺口判断,距前低天YA)!=1) OR REF(低保留X,距前低天YA)=0,1,0);


判断YX:=IF(局部高点预选C=1 AND REF(距前低天YA,1)<=REF(距前高天YA,1) AND 预判YX=1 AND 大值周期>REF(小值周期,距前低天YA+1) AND


大值周期>REF(小值周期,距前低天YA) AND 大值周期>REF(大值周期,距前高天YA),1,0);


高保留YXA:=IF(局部高点预选C=1 AND REF(距前低天YA,1)>REF(距前高天YA,1) AND HHV(H,距前低天YA+1)>REF(HHV(H,距前低天YA+1),1),1,0);


高保留YXB:=IF(局部高点预选C=1 AND REF(距前低天YA,1)<=REF(距前高天YA,1) AND REF(低保留X,距前低天YA)=-1 AND (距前低天YA>=4 OR


HHV(缺口判断,距前低天YA)=1),1,0);


高保留YX:=IF((高保留YXA=1 OR 高保留YXB=1 OR 判断YX=1) AND H>REF(L,距前低天YA+1),1,0);


预判YXA:=IF((距前高天YA<4 AND HHV(缺口判断,距前高天YA)!=1) OR REF(高保留YXA,距前高天YA)=0,1,0);


判断YXA:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)<=REF(距前低天YA,1) AND 预判YXA=1 AND 小值周期>REF(大值周期,距前高天YA+1)


AND 小值周期>REF(大值周期,距前高天YA) AND 小值周期>REF(小值周期,距前低天YA),-1,0);


低保留YXA:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)>REF(距前低天YA,1) AND LLV(L,距前高天YA+1)<REF(LLV(L,距前高天YA+1),1),-


1,0);


低保留YXB:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)<=REF(距前低天YA,1) AND (距前高天YA>=4 OR LLV(缺口判断,距前高天YA)=-1 OR


判断YXA=-1),-1,0);


低保留YX:=IF((低保留YXA=-1 OR 低保留YXB=-1) AND L<REF(H,距前高天YA+1),-1,0);


AAAD:=IF(高保留YX=1 AND 低保留YX=-1 AND H>REF(H,REF(距前高天YA,1)+2),1,IF(高保留YX=1 AND 低保留YX=-1 AND L<REF(L,REF(距前低天YA,1)+2),-1,0));


极点保留:=IF(AAAD=0,高保留YX+低保留YX,AAAD);


局部极点:IF(极点保留=-1,L,IF(极点保留=1,H,DRAWNULL)) CIRCLEDOT COLORYELLOW;


STICKLINE(C>REF(C,1)*1.099,C,O,2.7,0)COLORRED,LINETHICK2;


STICKLINE(C<REF(C,1)*0.901,C,O,2.7,0)COLORGREEN,LINETHICK2;


DRAWLINE(极点保留=-1,局部极点,极点保留=1,局部极点,0),COLORRED;


DRAWLINE(极点保留=1,局部极点,极点保留=-1,局部极点,0),COLORGREEN;


DD1:=BARSLAST(ABS(极点保留)!=1);


DRAWICON(极点保留=1,局部极点,2);


DRAWICON(极点保留=-1,局部极点,1);


{MA5:MA(CLOSE,5),COLORMAGENTA,LINETHICK1;


判:IF(MA5<REF(MA5,1),MA5,DRAWNULL),COLORCYAN,LINETHICK1;};


V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);


STICKLINE(V2>=1,O,C,1,0),COLORYELLOW;


TY:=C;{收盘价}


A1:=REF(TY,10)=HHV(TY,2*10+1);{10日前收盘价等于21天内最高价}


VB1:=FILTER(A1,10);{当出现A1条件时,过滤10天后连续出现的信号}


C1:=BACKSET(VB1,10+1);{将当前位置到11天前的位置设为1}


HD:=FILTER(C1,10);{将当前位置到10天后的位置设为1}


A2:=REF(TY,10)=LLV(TY,2*10+1);{10天前的收盘价等于21天内最低价}


VB2:=FILTER(A2,10); {过滤10天内连续出现的信号}


C2:=BACKSET(VB2,10+1);{将当前位置到11天前的位置设为1}


LD:=FILTER(C2,10);{当出现C2后,10天后的数据不予记录}


A:=REF(C,BARSLAST(HD));{设值上次高点位置}


B:=REF(C,BARSLAST(LD));{设值上次低点位置}


T11:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD);{上升波段回调不创新低没新高}


T21:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);{下降波段反弹不创新高没新低}


波峰:IF(T11,A,A),COLORFF00FF,POINTDOT;{符合T1条件,高位线为紫色点状线}


STICKLINE(T11,A,A,9,0),COLORFF00FF;{高位画横线}


波谷:IF(T21,B,B),COLOR80FF00,POINTDOT;{符合T2条件,高位线为绿色点状线}


STICKLINE(T21,B,B,9,0),COLOR80FF00;{低位画横线};




超强波段副图

QW1:=(HIGH+LOW+CLOSE*2)/4;

QW3:=EMA(QW1,10);

QW4:=STD(QW1,10);

QW5:=(QW1-QW3)*100/QW4;

QW6:=EMA(QW5,5);

RK7:=EMA(QW6,10);

涨:EMA(QW6,10)+100/2-5,LINETHICK1,COLORRED;

跌:EMA(涨,4),LINETHICK1,COLORFFFF34;

多线:IF(CROSS(涨,跌) AND 跌<-10,30,0),LINETHICK1,COLORFF00FF;

空线:IF(CROSS(跌,80),70,100),COLOR0099FF,LINETHICK1;

买1:EMA(跌,4),COLORWHITE;

买2:EMA(买1,4),COLORGREEN;

买M3:=EMA(买2,4);

买M4:=EMA(买M3,4);

-10,POINTDOT,COLOR888888,LINETHICK2;

80,POINTDOT,COLOR888888,LINETHICK2;

STICKLINE(涨<REF(涨,1),涨,MA(涨,3),2,0 ),COLOR00EE00;

STICKLINE(涨<REF(涨,1),涨,MA(涨,3),1,0 ),COLOR00FF00;

STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),3,0) ,COLOR0099FF;

STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),2,0) ,COLOR00AAFF;

STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),1,0) ,COLOR00BBFF;

DRAWICON(多线,30,1),COLORFF00FF;

DRAWICON(CROSS(跌,80),70,2),COLORGREEN;

DRAWTEXT(CROSS(涨,跌) AND 跌<20 AND 跌>-10,40,'买入'),COLORCCFF99;

DRAWTEXT(多线>0,-20,'看涨'),COLOR0000FF;

VAR2:=MA(CLOSE,194);

VAR3:=VAR2+2*STD(CLOSE,170);

顶:(CLOSE>VAR3)*13*10,COLORBLUE,LINETHICK2;

VAR18:=HHV(HIGH,30);

VAR19:=LLV(LOW,30);

NL:=EMA((CLOSE-VAR19)/(VAR18-VAR19)*100,5)/8*10;

DRAWTEXT(CROSS(5,NL),30,'★做底'),COLORWHITE;

VAR44:=REF(CLOSE,1);

VAR45:=SMA(MAX(CLOSE-VAR44,0),6,1)/SMA(ABS(CLOSE-VAR44),6,1)*100;

STICKLINE(CROSS(84,VAR45),0,VAR2*15+3,3,1),COLORGREEN;

DRAWTEXT(CROSS(84,VAR45),80,'防空警报'),COLORGREEN;

VAR55:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,5);

VAR56:=INDEXC;

VAR57:=MA(VAR56,5);

VAR58:=MA(VAR56,20);

VAR5B:=VAR57>VAR56*1.03 AND VAR58>VAR56*1.13;

VAR5D:=IF(FILTER(VAR55<6,5)=1,1,0);

VAR5F:=VAR55<6 AND VAR5B;

VAR61:=VAR5F AND VAR5D*80;

VAR7C:=IF(EMA(CLOSE,5)/EMA(EMA(CLOSE,9),16)<=0.85 AND CLOSE/REF(CLOSE,1)>0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,50,0);

VAR7D:=(-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))+100;

VAR7E:=(-100)*(HHV(HIGH,50)-CLOSE)/(HHV(HIGH,50)-LLV(LOW,50))+100;

VAR7F:=(-100)*(HHV(HIGH,70)-CLOSE)/(HHV(HIGH,70)-LLV(LOW,70))+100;

VAR80:=((CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100+10)*5;

VAR81:=((CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100+10)*5;

VAR82:=((CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+10)*5;

VAR83:=(VAR7D+VAR7E+VAR7F+VAR80+VAR81+VAR82)/6;

VAR84:=EMA(VAR83,3);

VAR85:=ABS(VAR80-VAR82);

VAR86:=(VAR83+VAR85)/2;

VAR87:=(-1)*(EMA(100*(1-WINNER(CLOSE)),1)-50)+50;

VAR88:=VAR87+VAR86;

VAR89:=IF(VAR7C>0 AND VAR88<0,200,0);

VAR8A:=IF(VAR86<0 AND CLOSE=LLV(CLOSE,5) AND CLOSE/REF(CLOSE,1)>0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,-50,0);

VAR8B:=IF(VAR88<0 AND VAR8A=-50,100,0);

VAR8D:=REF(CLOSE,2)*0.865;

VAR8E:=REF(CLOSE,13)*0.772;

VAR8F:=MIN(VAR8D,VAR8E);

VAR90:=100*VOL/CAPITAL;

VAR92:=IF((CLOSE-VAR8F)/CLOSE<0.03 AND SUM(VAR90,5)/5<1.8,1,0);

VAR96:=(VAR89>0 AND VAR8B>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR VAR92>0) AND (VAR8A<0 OR VAR7C>0);

VAR97:=VAR89>0 AND VAR8B>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR VAR92>0 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902;

VAR98:=VAR96 OR VAR97;

VARA4:=AMOUNT/VOL/100;

VARA5:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;

VARA7:=SUM(AMOUNT,13)/VARA4/100;

VARAE:=DMA(VARA5,VOL/VARA7);

VARB1:=MA(HHV(HIGH,488),18);

VARB2:=MA(HHV(HIGH,220),18);

VARB3:=MA(HHV(HIGH,98),18);

VARB4:=MA(LLV(LOW,488),18);

VARB5:=MA(LLV(LOW,220),18);

VARB6:=MA(LLV(LOW,98),18);

VARB7:=MA((VARB4*0.96+VARB5*0.96+VARB6*0.96+VARB1*0.558+VARB2*0.558+VARB3*0.558)/6,18);

VARB8:=MA((VARB4*1.25+VARB5*1.23+VARB6*1.2+VARB1*0.55+VARB2*0.55+VARB3*0.65)/6,18);

VARB9:=MA((VARB4*1.3+VARB5*1.3+VARB6*1.3+VARB1*0.68+VARB2*0.68+VARB3*0.68)/6,18);

VARBA:=MA((VARB7*3+VARB8*2+VARB9)/6*1.738,18);

VARBC:=LOW;

VARBD:=REF(LOW,1);

VARBE:=SMA(ABS(VARBC-VARBD),3,1)/SMA(MAX(VARBC-VARBD,0),3,1)*100;

VARBF:=MA(IF(CLOSE*1.35<=VARBA,VARBE*10,VARBE/10),3);

VARC0:=LLV(LOW,30);

VARC1:=HHV(VARBF,30);

VARC2:=IF(LOW<=VARC0,(VARBF+VARC1*2)/2,0);

WXBM:(MA(VARC2 AND CLOSE<COST(1),3) AND (CLOSE-VARAE)/VARAE*100<-11)*118,COLORRED,LINETHICK2;

DRAWTEXT(VAR61 OR VAR98,70,'★大黑马'),COLORYELLOW;

DRAWTEXT(WXBM,100,'BM'),COLORRED;

STICKLINE(VAR61,0,120,3,0),COLORWHITE;

STICKLINE(VAR98,0,90,3,0),COLORYELLOW;

X:=C-REF(MA(C,20),11);

LGL:=IF(EMA(C,5)/EMA(EMA(C,9),16)<=0.85 AND C/REF(C,1)>0.905 AND C/REF(C,1)<1.05 AND VOL/CAPITAL*100<5,50,0);

WR1:=-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))+100*X;

WR2:=-100*(HHV(HIGH,50)-CLOSE)/(HHV(HIGH,50)-LLV(LOW,50))+100;

WR3:=-100*(HHV(HIGH,70)-CLOSE)/(HHV(HIGH,70)-LLV(LOW,70))+100*X;

BIAS1:=((CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100+10)*5;

BIAS2:=((CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100+10)*5;

BIAS3:=((CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+10)*5;

S1:=(WR1+WR2+WR3+BIAS1+BIAS2+BIAS3)/6*X;

S2:=EMA(S1,3);

S3:=ABS(BIAS1-BIAS3);

SX:=(S1+S3)/2;

XC1:=(-1)*(EMA(100*(1-WINNER(CLOSE)),1)-50)+50;

CCC:=XC1+SX;

ZJZ:=IF( LGL>0 AND CCC<0,200,0)*X;

LXL:=IF(SX<0 AND C=LLV(C,5) AND C/REF(C,1)>0.905 AND C/REF(C,1)<1.05 AND VOL/CAPITAL*100<5,-50,0);

JBJ:=IF(CCC<0 AND LXL=-50,100,0)*X;

MA3:= MA(C,3);

C0:=REF(C,2)*0.865;

C1:=REF(C,13)*0.772;

BOT:=MIN(C0,C1);

HSL:=100*VOL/CAPITAL*X;

MA13:=MA(C,13)*X;

CXC:=IF((C-BOT)/C<3/100 AND SUM(HSL,5)/5<1.8,1,0);

VMC:=IF(CXC>0 AND (LXL<0 OR LGL>0),10,0);

满仓:IF((VMC>0),120,0),COLORRED,LINETHICK3;

DRAWTEXT(满仓>0 AND REF(满仓,1)=0,100,'满仓'),COLORRED;

半仓:IF(((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR (CXC>0 AND REF(C,1)/REF(C,2)>0.902)) OR (((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR CXC>0) AND (LXL<0 OR LGL>0)) AND VMC<10 ,100,0),COLORMAGENTA,LINETHICK2;

V93:=(((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR CXC>0) AND (LXL<0 OR LGL>0)) ;

V90:=((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR (CXC>0 AND REF(C,1)/REF(C,2)>0.902));

买11:IF((V93 OR V90),80,0),COLORYELLOW,LINETHICK2;

VAR2Q:=(MA(CLOSE,80)-MA(CLOSE,13)/3);

神奇线:= MA((CLOSE-VAR2Q)/VAR2Q,2);

买12:IF(CROSS(神奇线,0) AND LOW/REF(HIGH,1)<1.012 AND ((C-REF(C,2))/C)>0.06,100,0),COLORMAGENTA,LINETHICK2;

YY:=SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,18,1),12,1);

YT:=SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,12,1);

ST:=IF(CROSS(YT,YY),30,0);

VAR5PT:=(HIGH+LOW+CLOSE)/3;

VAR6PT:=(VAR5PT-MA(VAR5PT,14))/(0.015*AVEDEV(VAR5PT,14));

VAR7PT:=(VAR5PT-MA(VAR5PT,85))/(0.015*AVEDEV(VAR5PT,85));

SA:=IF(VAR7PT>=200 AND VAR6PT>=150,10,0);

VAR3AA:=REF(CLOSE,1);

VAR4AA:=SMA(MAX(CLOSE-VAR3AA,0),6,1)/SMA(ABS(CLOSE-VAR3AA),6,1)*100;

SM:=IF(CROSS(80,VAR4AA),100,0);

卖11:IF((SM AND (SA OR ST)),120,0),COLORCCCC33,LINETHICK2;

DRAWTEXT( 卖11>0,110,''),COLORCCCC33;

XX2:=(MA(CLOSE,80)-MA(CLOSE,13)/3);

SQX:=MA((CLOSE-XX2)/XX2,10)*0.01;

买3:IF(CROSS(SQX,0) AND LOW/REF(HIGH,1)<1.012,60,0), STICK,COLORWHITE,LINETHICK2;

稳赚:IF(COUNT(SQX>REF(SQX,1),3)=3 AND COUNT(SQX<0,10)=10 AND REF(SQX,3)=LLV(SQX,10),60,0),COLOR9999FF;

买4: IF(REF(SQX,2)=LLV(SQX,20) AND REF(SQX,2)<0.071 AND REF(SQX,2)<REF(SQX,1) AND NOT(REF(LOW,1)>REF(HIGH,2) AND LOW>REF(HIGH,1)) AND CLOSE>REF(CLOSE,1),60,0),COLORFF00FF,LINETHICK2;

DRAWTEXT( 买3>0,40 ,' 买3'),COLORWHITE;

DRAWTEXT( 稳赚>0,40 ,'稳赚'),COLOR9999FF;

DRAWTEXT( 买4>0,40 , '买4'),COLORFF00FF;



超强潜伏副图选股一体

X_1:=EMA(SLOPE(CLOSE,34)*20+CLOSE,75);

X_2:=EMA(CLOSE,8);

X_3:=X_2-X_1;

X_4:=X_3>=0;

X_5:=X_3<0;

X_6:=HHV(HIGH,50)-LLV(LOW,50);

X_7:=X_3>=0 AND REF(X_3<0,1) AND COUNT(X_3>=0,6)<=1;

X_8:=MA(CLOSE,1)-MA(CLOSE,6);

X_9:=X_8>0;

X_10:=X_8<0;

X_11:=CROSS(X_8,0);

X_12:=(2*CLOSE+HIGH+LOW+OPEN)/5;

X_13:=(X_12-MA(X_12,14))*100/(1.5*AVEDEV(X_12,14));

X_14:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;

X_15:=X_14<25;

X_16:=VOL*100/CAPITAL;

X_17:=MA(X_16,4);

X_18:=MA(X_16,8);

X_19:=MA(X_16,16);

X_20:=MA(X_16,32);

X_21:=MA(CLOSE,50);

X_22:=(CLOSE-X_21)/X_21<0.008;

X_23:=(CLOSE-MA(CLOSE,8))/MA(CLOSE,8)<0.058;

X_24:=(X_22=1 AND X_23=1)*0.2;

X_25:=(X_24=0 AND REF(X_24,1)=0.2 AND REF(COUNT(X_24=0.2,10)=10,1)=1)*1;

X_26:=HHV(REF(VOL,1),5);

X_27:=BARSLAST(X_26);

X_28:=VOL>X_26 AND CLOSE>REF(CLOSE,X_27+1);

X_29:=X_17>=X_20 AND REF(X_17<X_20,1) AND COUNT(X_19,10)<=2 AND (CLOSE-REF(CLOSE,3))/REF(CLOSE,3)<=0.15;

X_30:=X_17>X_20 AND X_18>X_20 AND X_19<X_20 AND REF(X_18<X_20,1);

X_31:=X_17>X_20 AND X_18>X_20 AND X_19>X_20 AND REF(X_19<X_20,1) AND COUNT(X_18<X_20,3)<=1;

X_32:=X_30 OR X_31;

X_33:=COUNT(X_19,10)<=1;

X_34:=(CLOSE-REF(CLOSE,9))/REF(CLOSE,9)<=0.14;

X_35:=X_32 AND COUNT(X_19,10)<=1 AND X_34;

X_36:=X_17<X_20 AND X_18>=X_20 AND X_19<X_20 AND REF(X_18<X_20,1) AND (CLOSE-REF(CLOSE,10))/REF(CLOSE,10)<=0.28 AND COUNT(X_19,10)<=2;

X_37:=X_11 AND COUNT(X_19,20)<=3 AND X_34;

X_38:=X_18>=X_20 AND X_17>X_20 AND X_19<X_20 AND COUNT(X_19,9)<=1 AND (CLOSE-REF(CLOSE,7))/REF(CLOSE,7)<=0.1;

X_39:=X_17>X_20 AND X_19<X_20 AND X_18<X_20 AND REF(X_17<X_20,1) AND COUNT(X_19,6)=0;

X_40:=X_17>X_18 AND X_18>=X_19 AND X_19>X_20 AND COUNT(X_19,10)<=2 AND (CLOSE-REF(CLOSE,7))/REF(CLOSE,7)<=0.04 AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=(-0.05);

X_41:=X_15 AND COUNT(X_29,14)>=1 AND COUNT(X_35,14)>=1;

X_42:=COUNT(X_19,12)<=1 AND (CLOSE-REF(CLOSE,9))/REF(CLOSE,9)<=0.12;

X_43:=COUNT(X_42,6)>=5;

X_44:=X_29 OR X_35 OR X_36 OR X_37 OR X_38 OR X_39 OR X_40 OR X_41 OR X_42 OR X_43;

X_45:=VOL/REF(VOL,1);

X_46:=REF(CLOSE,1)/REF(CLOSE,8);

X_47:=HHV(REF(CLOSE,1),12)/LLV(REF(CLOSE,1),12);

X_48:=COUNT(X_44,20)>=1 AND X_45>=2.7 AND CLOSE>REF(CLOSE,1);

X_49:=BARSLAST(CROSS(MA(CLOSE,5),MA(CLOSE,10)));

X_50:=BARSLAST(CROSS(MA(CLOSE,10),MA(CLOSE,5)));

X_51:=IF(X_49<X_50,X_49+1,0);

X_52:=MA(CLOSE,5)>MA(CLOSE,20) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,20)>REF(MA(CLOSE,20),1) AND MA(CLOSE,30)>REF(MA(CLOSE,30),1);

X_53:=X_51*X_52;

X_54:=HHV(X_51,5)>=2 AND X_52 AND MA(CLOSE,5)>REF(MA(CLOSE,5),1) AND MA(CLOSE,5)>MA(CLOSE,10);

X_55:=X_54*X_51;

X_56:=X_53>0 AND X_55=0;

X_57:=ATAN((MA(CLOSE,5)/REF(MA(CLOSE,5),1)-1)*100)*180/3.14159;

X_58:=X_57>REF(X_57,1) AND REF(X_57,1)<REF(X_57,2);

X_59:=MA(CLOSE,5)>REF(MA(CLOSE,5),1) AND REF(MA(CLOSE,5),1)<REF(MA(CLOSE,5),2);

X_60:=FILTER(X_58 OR X_59 AND CLOSE>MA(CLOSE,5) AND X_54,3);

X_61:=X_55>0 AND REF(X_55,1)=0 AND COUNT(X_44,7)>=1;

X_62:=COUNT(X_25,10)>=1 AND COUNT(X_28,10)>=2 AND COUNT(X_7,10)>=1 AND COUNT(X_48,10)>=1 AND COUNT(X_61,2)>=1 AND CLOSE>OPEN;

X_63:=EMA(CLOSE,4);

X_64:=EMA(SLOPE(CLOSE,20)*10+CLOSE,35);

X_65:=CROSS(X_63,X_64);

X_66:=EMA(CLOSE,3);

X_67:=EMA(CLOSE,21);

X_68:=KDJ.J<50;

X_69:=CROSS(KDJ.J,KDJ.D) AND CROSS(KDJ.J,KDJ.K);

X_70:=CROSS(X_63,X_64) AND X_69;

X_71:=CROSS(X_66,X_67) AND X_70;

X_72:=AMOUNT/VOL;

X_73:=LOW<X_72*0.9;

X_74:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>1.2;

X_75:=LOW<MA(CLOSE,5)*0.921;

X_76:=VOL<MA(VOL,5)*1.5;

X_77:=MACD.MACD>0;

X_78:=X_73 AND X_74 AND X_75 AND X_76 AND X_77;

X_78 OR (X_62 AND X_71);



各种股票资料学习指标 淘股吧理想论坛大咖观点技术直播等团购微信,有兴趣的朋友可添加微信  


备用号 gpxx68


主号  gupiaoxuexi2020   (暂时被封7天加不了也看不到朋友圈)




标签 MAREFCLOSEEMABARSLAST

声明:
1. 版权归原作者“通达信指标爱好者”所有, 本文转载目的在于 股票财经 爱好者个人学习使用,并不代表吉发网赞同其观点和对其真实性负责。如有侵权行为,请联系站长(webmaster@666888.net.cn),站长会尽最大努力及时删除。
2. 吉发网不提供在线交流(评论)功能,如喜欢作者的文章请点击 关注作者 扫描二维码关注"通达信指标爱好者"后,与作者交流留言。
3. 如文章出现QQ号、QQ群、微信号、微信群,请仔细甄别,不要轻信所谓NB的战法、NB的讲师、股票推荐、不收任何费用、万人建仓等蛊惑性描述,如遭到财产损失,不要犹豫立即报警!立即报警!立即报警!
4. 欢迎推荐或自荐优秀股市财经金融公众号加入吉发网, 既可以涨粉,又能帮助股票财经爱好者学习成长,多有意义啊^_^。
5. 吉发网不接受广告合作,不接受链接交换,相关邮件一律不回!



选股最新文章列表

















相关文章列表


昨日热门文章

本周热门文章

本月热门文章

股票标签云


炒股知识大全