通达信指标公式源码全方位操盘主图指标公式



做价值的传播者,路同行,一起成长

问题怎样才能每天都收到这类文章!

答案只需点击上方《通达信公式指标

MA10:MA(C,10);


MA60:MA(C,60);


VAR6:=(( ABS((OPEN-CLOSE))/(HIGH-LOW))*VOL);


VAR7:=(( (HIGH-IF((CLOSE>OPEN),CLOSE,OPEN))/(HIGH-LOW))*VOL);


VAR8:=(( (IF((CLOSE>OPEN),OPEN,CLOSE)-LOW)/(HIGH-LOW))*VOL);


VAR9:=IF(((VOL/CAPITAL)>0.001),1,EXP(ABS(LOG(((VOL/CAPITAL)*100)))));


加仓:VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE>OPEN,NODRAW,COLORRED;


减仓:VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE<OPEN,NODRAW,COLORBLUE;


洗盘:VAR8>VAR6 AND VAR8>VAR7,NODRAW,COLORWHITE;

高抛:VAR7>VAR6 AND VAR7>VAR8,NODRAW,COLORMAGENTA;


地量:VAR9>2 AND VOL<MA(VOL,5)/2,NODRAW,COLORGREEN;


DRAWKLINE(H,O,L,C);


TY:=C;


A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);


A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);


前期高位:REF(H,BARSLAST(HD)), COLORFF00FF,POINTDOT,LINETHICK3;


前期低位:REF(L,BARSLAST(LD)), COLORGREEN,POINTDOT,LINETHICK3;


STICKLINE(加仓,O,C,1,0),COLORRED;


STICKLINE(洗盘,O,C,1,0),COLORWHITE;


STICKLINE(减仓,O,C,1,0),COLORBLUE;


STICKLINE(高抛,O,C,1,0),COLORMAGENTA;


STICKLINE(地量,O,C,1,0),COLORGREEN;

JJ:=(3*C+H+L+O)/6;


VAR1:=(8*JJ+7*REF(JJ,1)+6*REF(JJ,2)+5*REF(JJ,3)+4*REF(JJ,4)+3*REF(JJ,5)+2*REF(JJ,6)+REF(JJ,8))/36;


TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1 AND C>REF(C,1);


LJL:=FILTER(TJ1,5);


STICKLINE(CLOSE,REF(LOW,BARSLAST(LJL)),REF(LOW,BARSLAST(LJL)),1,0),COLORRED;


STICKLINE(CLOSE,REF(CLOSE,BARSLAST(LJL)),REF(CLOSE,BARSLAST(LJL)),1,0),COLORYELLOW;


STICKLINE(LJL,OPEN,CLOSE,1,0),COLORYELLOW;


DRAWTEXT_FIX(1,0.0,0.0,0,'蓝芯-主力低位深度洗盘或高位出货坚决'),COLORBLUE,LINETHICK1;{买好股公式}


DRAWTEXT_FIX(1,0.00,0.06,0,'白芯-主力轻度洗盘'),COLORWHITE,LINETHICK1;


DRAWTEXT_FIX(1,0.00,0.12,0,'棕芯-出现了近期相对地量'),COLORGREEN,LINETHICK1;


DRAWTEXT_FIX(1,0.00,0.18,0,'粉芯-主力在做高抛低吸或低吸高抛'),COLORFF00FF,LINETHICK1;


DRAWTEXT_FIX(1,0.00,0.24,0,'红芯-主力吸筹进货积极主动'),COLORRED,LINETHICK1;


DRAWTEXT_FIX(1,0.00,0.3,0,'黄芯-主力吸筹进货强并且成交量出现黄金柱'),COLORYELLOW,LINETHICK1;


DRAWTEXT_FIX(C>0,0.004,1,0,DYBLOCK),COLORYELLOW,LINETHICK2;


DRAWTEXT_FIX(C>0,0.06,1,0,HYBLOCK),COLORRED,LINETHICK2;


DRAWTEXT_FIX(C>0,0.12,1,0,EXTERNSTR(0,1)),COLORWHITE,LINETHICK2;


EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);


PL10:=ZIG(3,10);


走强2:=BARSLAST(PL10<REF(PL10,1));


ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);


追2:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2;


追4:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3;


DRAWTEXT(追2 OR 追4,LOW*0.978,'追'),COLORYELLOW;


PL5:=ZIG(3,5);


EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);


EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);


EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);


PL20:=ZIG(3,20);


EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);


EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);


PL40:=ZIG(3,40);


走强1:=BARSLAST(PL5<REF(PL5,1));


走弱1:=BARSLAST(PL5>REF(PL5,1));


走弱2:=BARSLAST(PL10>REF(PL10,1));


走强3:=BARSLAST(PL20<REF(PL20,1));


走弱3:=BARSLAST(PL20>REF(PL20,1));


{ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);}


ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);


DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);


DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);


ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0);


ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);


DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);


DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);


DRAWTEXT(EN1 AND DTJZ5=1,L*0.98,'反弹低点'),COLORLIRED;


DRAWTEXT(EX1 AND DTJD5=2,H*1.02,'反弹高点!'),COLORLIBLUE;


DRAWTEXT(EN2 AND ZTJZ5=1,L*0.98,'底'),COLORYELLOW;


DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJD5=1,H*1.02,'减仓'),COLORFFFF00;


DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2,L*0.98,'----买'),COLOR0000FF;


DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJZ5=2,H*1.02,'短卖'),COLORGREEN;


DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.98,'----短买'),COLOR0000FF;


DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.02,'短卖'),COLORGREEN;


DRAWTEXT(EN2 AND DTJZ10=1,L*0.96,'Ⅰ'),COLORFF00FF;


DRAWTEXT(EX2 AND DTJD10=2,H*1.03,'Ⅱ'),COLORFF6000;


DRAWTEXT(EN3 AND ZTJZ10=1,L*0.95,'Ⅲ'),COLORYELLOW;


DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.06,'①'),LINETHICK3,COLORFFFF00;


DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L*0.96,'②'),LINETHICK3,COLORYELLOW;


DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2) AND EX2,H*1.02,'清仓!'),LINETHICK3,COLORWHITE;


DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3,L*0.96,'④'),LINETHICK3,COLORYELLOW;


DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.95,'⑷'),COLORYELLOW;


EMA13:=EMA(C,13);


EMA34:=EMA(C,34);


EMA55:=EMA(C,55);


EMA120:=EMA(C,120);


CR1:=(C-REF(C,1))/REF(C,1)*100>0.5;


CR2:=V>MA(V,5)*0.6;


CR3:=COUNT(CROSS(EMA13,EMA55),3)=1;


CR4:=ABS(EMA34-EMA55)/EMA55<0.03;


CR5:=EMA55<=EMA120 AND EMA55>=REF(EMA55,1);


CR6:=FILTER(CR1 AND CR2 AND CR3 AND CR4 AND CR5,2);


DRAWTEXT(CR6,C*0.98,'风险'),COLORWHITE;

风险提示:本指标公式仅作为知识分享,不构成任何投资建议,不作投资依据。


=====================

提供服务如下:

1、转换 --- 根据客户提供的电脑板或者手机版技术指标源码,转换成自己的手机软件使用

2、编写 --- 按照客户定制指标时“提供的编写要求”,制作技术指标

3、修改 --- 按照客户“提供的修改要求”,修改技术指标


点击阅读原文查阅更多经典指标


标签 REFFILTERVOL指标ZIG

声明:
1. 版权归原作者“通达信公式指标”所有, 本文转载目的在于 股票财经 爱好者个人学习使用,并不代表吉发网赞同其观点和对其真实性负责。如有侵权行为,请联系站长(webmaster@666888.net.cn),站长会尽最大努力及时删除。
2. 吉发网不提供在线交流(评论)功能,如喜欢作者的文章请点击 关注作者 扫描二维码关注"通达信公式指标"后,与作者交流留言。
3. 如文章出现QQ号、QQ群、微信号、微信群,请仔细甄别,不要轻信所谓NB的战法、NB的讲师、股票推荐、不收任何费用、万人建仓等蛊惑性描述,如遭到财产损失,不要犹豫立即报警!立即报警!立即报警!
4. 欢迎推荐或自荐优秀股市财经金融公众号加入吉发网, 既可以涨粉,又能帮助股票财经爱好者学习成长,多有意义啊^_^。
5. 吉发网不接受广告合作,不接受链接交换,相关邮件一律不回!



技术指标最新文章列表

















相关文章列表


昨日热门文章

本周热门文章

本月热门文章

股票标签云


炒股知识大全