【精华指标】三角形中枢缠论自动划线主图公式 源码



指标仅供学习参考研究之用,不能直接作为股票买卖依据,可以结合自身经验和大盘环境进行综合判断,依此操作盈亏自负。公 式 是死 的,人 是 活 的。灵 活 运 用,仅 供 参 考。            
三角形中枢缠论自动划线主图公式 源码



缠论中枢思想是前三笔为主的中枢画线,本指标以近三笔为主作出的中枢画线。

黄色紫色上升中枢,绿色蓝色下跌中枢;
虚线中枢未走完,全实线表示中枢成立。

{三角形中枢}

时间:=4;
A:=H=HHV(H,时间*5) AND HHV(H,时间*5)>REF(HHV(H,时间*5),1);
B:=L=LLV(L,时间*5) AND LLV(L,时间*5)<REF(LLV(L,时间*5),1);
CC1:DRAWLINE(A,H,B,L,0);
CC2:DRAWLINE(B,L,A,H,0);

N:=(0,1,1);
{缠论高低点}
局部低点预选A:=BACKSET(LLV(L,5)<REF(LLV(L,4),1),4);
局部低点预选B:=BACKSET(局部低点预选A=0 AND REF(局部低点预选A,1)=1,2);
局部低点预选C:=IF(局部低点预选B=1 AND REF(局部低点预选B,1)=0,-1,0);
局部高点预选A:=BACKSET(HHV(H,5)>REF(HHV(H,4),1),4);
局部高点预选B:=BACKSET(局部高点预选A=0 AND REF(局部高点预选A,1)=1,2);
局部高点预选C:=IF(局部高点预选B=1 AND REF(局部高点预选B,1)=0,1,0);
缺口判断:=IF(L>REF(H,1),1,IF(H<REF(L,1),-1,0));
距前高天:=BARSLAST(局部高点预选C=1);
距前低天:=BARSLAST(局部低点预选C=-1);
小值周期:=LOWRANGE(L);
大值周期:=TOPRANGE(H);
低保留AA:=IF(局部低点预选C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)<REF(LLV(L,距前高天+1),1),-1,0);
低保留AB:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND (距前高天>=4 OR LLV(缺口判断,距前高天)=-1 OR LLV(L,距前低天+2)<REF(LLV(L,距前低天+1),1)),-1,0);
低保留S:=IF((低保留AA=-1 OR 低保留AB=-1) AND L<REF(H,距前高天+1),-1,0);
预判:=IF((距前低天<4 AND HHV(缺口判断,距前低天)!=1) OR REF(低保留S,距前低天)=0,1,0);
判断:=IF(局部高点预选C=1 AND REF(距前低天,1)<=REF(距前高天,1) AND 预判=1 AND 大值周期>REF(小值周期,距前低天+1) AND 大值周期>REF(小值周期,距前低天) AND 大值周期>REF(大值周期,距前高天),1,0);
高保留A:=IF(局部高点预选C=1 AND REF(距前低天,1)>REF(距前高天,1) AND HHV(H,距前低天+1)>REF(HHV(H,距前低天+1),1),1,0);
高保留B:=IF(局部高点预选C=1 AND REF(距前低天,1)<=REF(距前高天,1) AND REF(低保留S,距前低天)=-1 AND (距前低天>=4 OR HHV(缺口判断,距前低天)=1),1,0);
高保留:=IF((高保留A=1 OR 高保留B=1 OR 判断=1) AND H>REF(L,距前低天+1),1,0);
预判A:=IF((距前高天<4 AND HHV(缺口判断,距前高天)!=1) OR REF(高保留,距前高天)=0,1,0);
判断A:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND 预判A=1 AND 小值周期>REF(大值周期,距前高天+1) AND 小值周期>REF(大值周期,距前高天) AND 小值周期>REF(小值周期,距前低天),-1,0);
低保留A:=IF(局部低点预选C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)<REF(LLV(L,距前高天+1),1),-1,0);
低保留B:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND (距前高天>=4 OR LLV(缺口判断,距前高天)=-1 OR 判断A=-1),-1,0);
低保留:=IF((低保留A=-1 OR 低保留B=-1) AND L<REF(H,距前高天+1),-1,0);
距前高天A:=BARSLAST(高保留=1);
距前低天A:=BARSLAST(低保留=-1);
预判X:=IF((距前低天A<4 AND HHV(缺口判断,距前低天A)!=1) OR REF(低保留,距前低天A)=0,1,0);
判断X:=IF(局部高点预选C=1 AND REF(距前低天A,1)<=REF(距前高天A,1) AND 预判X=1 AND 大值周期>REF(小值周期,距前低天A+1) AND 大值周期>REF(小值周期,距前低天A) AND 大值周期>REF(大值周期,距前高天A),1,0);
高保留XA:=IF(局部高点预选C=1 AND REF(距前低天A,1)>REF(距前高天A,1) AND HHV(H,距前低天A+1)>REF(HHV(H,距前低天A+1),1),1,0);
高保留XB:=IF(局部高点预选C=1 AND REF(距前低天A,1)<=REF(距前高天A,1) AND REF(低保留,距前低天A)=-1 AND (距前低天A>=4 OR HHV(缺口判断,距前低天A)=1),1,0);
高保留X:=IF((高保留XA=1 OR 高保留XB=1 OR 判断X=1) AND H>REF(L,距前低天A+1),1,0);
预判XA:=IF((距前高天A<4 AND HHV(缺口判断,距前高天A)!=1) OR REF(高保留XA,距前高天A)=0,1,0);
判断XA:=IF(局部低点预选C=-1 AND REF(距前高天A,1)<=REF(距前低天A,1) AND 预判XA=1 AND 小值周期>REF(大值周期,距前高天A+1) AND 小值周期>REF(大值周期,距前高天A) AND 小值周期>REF(小值周期,距前低天A),-1,0);
低保留XA:=IF(局部低点预选C=-1 AND REF(距前高天A,1)>REF(距前低天A,1) AND LLV(L,距前高天A+1)<REF(LLV(L,距前高天A+1),1),-1,0);
低保留XB:=IF(局部低点预选C=-1 AND REF(距前高天A,1)<=REF(距前低天A,1) AND (距前高天A>=4 OR LLV(缺口判断,距前高天A)=-1 OR 判断XA=-1),-1,0);
低保留X:=IF((低保留XA=-1 OR 低保留XB=-1) AND L<REF(H,距前高天A+1),-1,0);
距前高天YA:=BARSLAST(高保留X=1);
距前低天YA:=BARSLAST(低保留X=-1);
预判YX:=IF((距前低天YA<4 AND HHV(缺口判断,距前低天YA)!=1) OR REF(低保留X,距前低天YA)=0,1,0);
判断YX:=IF(局部高点预选C=1 AND REF(距前低天YA,1)<=REF(距前高天YA,1) AND 预判YX=1 AND 大值周期>REF(小值周期,距前低天YA+1) AND 大值周期>REF(小值周期,距前低天YA) AND 大值周期>REF(大值周期,距前高天YA),1,0);
高保留YXA:=IF(局部高点预选C=1 AND REF(距前低天YA,1)>REF(距前高天YA,1) AND HHV(H,距前低天YA+1)>REF(HHV(H,距前低天YA+1),1),1,0);
高保留YXB:=IF(局部高点预选C=1 AND REF(距前低天YA,1)<=REF(距前高天YA,1) AND REF(低保留X,距前低天YA)=-1 AND (距前低天YA>=4 OR HHV(缺口判断,距前低天YA)=1),1,0);
高保留YX:=IF((高保留YXA=1 OR 高保留YXB=1 OR 判断YX=1) AND H>REF(L,距前低天YA+1),1,0);
预判YXA:=IF((距前高天YA<4 AND HHV(缺口判断,距前高天YA)!=1) OR REF(高保留YXA,距前高天YA)=0,1,0);
判断YXA:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)<=REF(距前低天YA,1) AND 预判YXA=1 AND 小值周期>REF(大值周期,距前高天YA+1) AND 小值周期>REF(大值周期,距前高天YA) AND 小值周期>REF(小值周期,距前低天YA),-1,0);
低保留YXA:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)>REF(距前低天YA,1) AND LLV(L,距前高天YA+1)<REF(LLV(L,距前高天YA+1),1),-1,0);
低保留YXB:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)<=REF(距前低天YA,1) AND (距前高天YA>=4 OR LLV(缺口判断,距前高天YA)=-1 OR 判断YXA=-1),-1,0);
低保留YX:=IF((低保留YXA=-1 OR 低保留YXB=-1) AND L<REF(H,距前高天YA+1),-1,0);
AAAD:=IF(高保留YX=1 AND 低保留YX=-1 AND H>REF(H,REF(距前高天YA,1)+2),1,IF(高保留YX=1 AND 低保留YX=-1 AND L<REF(L,REF(距前低天YA,1)+2),-1,0));
极点保留:=IF(AAAD=0,高保留YX+低保留YX,AAAD);
局部极点:IF(极点保留=-1,L,IF(极点保留=1,H,DRAWNULL)),CIRCLEDOT,COLORLIMAGENTA;
C1:DRAWLINE(极点保留=-1,局部极点,极点保留=1,局部极点,0),COLORLIGRAY;
C2:DRAWLINE(极点保留=1,局部极点,极点保留=-1,局部极点,0),COLORLIGRAY;
极顶:=IF(N=1,C2=C1 AND 局部高点预选A AND 极点保留=1,DRAWNULL);
极底:=IF(N=1,C2=C1 AND 局部低点预选A AND 极点保留=-1,DRAWNULL);
A1:=BARSLAST(极顶);B1:=CURRBARSCOUNT=CONST(A1)+1;D1:=BARSLAST(B1);高1:=CONST(REF(H,D1));
A2:=REF(A1,A1+1)+A1+1;B2:=CURRBARSCOUNT=CONST(A2)+1;D2:=BARSLAST(B2);高2:=CONST(REF(H,D2));
A3:=REF(A2,A1+1)+A1+1;B3:=CURRBARSCOUNT=CONST(A3)+1;D3:=BARSLAST(B3);高3:=CONST(REF(H,D3));
DA1:=BARSLAST(极底);DB1:=CURRBARSCOUNT=CONST(DA1)+1;DD1:=BARSLAST(DB1);低1:=CONST(REF(L,DD1));
DA2:=REF(DA1,DA1+1)+DA1+1;DB2:=CURRBARSCOUNT=CONST(DA2)+1;DD2:=BARSLAST(DB2);低2:=CONST(REF(L,DD2));
DA3:=REF(DA2,DA1+1)+DA1+1;DB3:=CURRBARSCOUNT=CONST(DA3)+1;DD3:=BARSLAST(DB3);低3:=CONST(REF(L,DD3));
三角型放大A:=低1<低2 AND 高2>高1 AND DA2>A1 AND A1>DA1 AND A2>DA2 AND CONST(C)>低2;
中枢A1:=IF(三角型放大A AND CONST(C)<高1,DB2,DRAWNULL);
STICKLINE(中枢A1,CONST(C),低2,0,0),COLORLIMAGENTA;
中枢A2:=IF(三角型放大A AND CONST(C)<高1,ISLASTBAR,DRAWNULL);
STICKLINE(中枢A2,CONST(C),低2,0,0),COLORLIMAGENTA;
DRAWLINE(中枢A1=1,CONST(C),中枢A2=1,CONST(C),0),DOTLINE,COLORLIMAGENTA;
DRAWLINE(中枢A1=1,低2,中枢A2=1,低2,0),COLORLIMAGENTA;
{成立}
中枢AC1:=IF(三角型放大A AND CONST(C)>=高1,DB2,DRAWNULL);
STICKLINE(中枢AC1,高1,低1,0,0),COLORLIMAGENTA;
中枢AC2:=IF(三角型放大A AND CONST(C)>=高1,ISLASTBAR,DRAWNULL);
STICKLINE(中枢AC2,高1,低1,0,0),COLORLIMAGENTA;
DRAWLINE(中枢AC1=1,高1,中枢AC2=1,高1,0),COLORLIMAGENTA;
DRAWLINE(中枢AC1=1,低1,中枢AC2=1,低1,0),COLORLIMAGENTA;
三角型放大B:=低1>低2 AND 高1>高2 AND DA1>A1 AND A2>DA1 AND DA2>A2 AND CONST(C)<高2;
中枢B1:=IF(三角型放大B AND CONST(C)>低1,B2,DRAWNULL);
STICKLINE(中枢B1,CONST(C),高2,0,0),COLORGREEN;
中枢B2:=IF(三角型放大B AND CONST(C)>低1,ISLASTBAR,DRAWNULL);
STICKLINE(中枢B2,CONST(C),高2,0,0),COLORGREEN;
DRAWLINE(中枢B1=1,高2,中枢B2=1,高2,0),COLORGREEN;
DRAWLINE(中枢B1=1,CONST(C),中枢B2=1,CONST(C),0),DOTLINE,COLORGREEN;
{成立}
中枢BC1:=IF(三角型放大B AND CONST(C)<=低1,B2,DRAWNULL);
STICKLINE(中枢BC1,高2,低1,0,0),COLORGREEN;
中枢BC2:=IF(三角型放大B AND CONST(C)<=低1,ISLASTBAR,DRAWNULL);
STICKLINE(中枢BC2,高2,低1,0,0),COLORGREEN;
DRAWLINE(中枢BC1=1,高2,中枢BC2=1,高2,0),COLORGREEN;
DRAWLINE(中枢BC1=1,低1,中枢BC2=1,低1,0),COLORGREEN;
三角型收敛A:=低1>低2 AND 高2>高1 AND DA2>A1 AND A1>DA1 AND A2>DA2 AND CONST(C)>低1;
中枢C1:=IF(三角型收敛A AND CONST(C)<高1,DB2,DRAWNULL);
STICKLINE(中枢C1,CONST(C),低1,0,0),COLORYELLOW;
中枢C2:=IF(三角型收敛A AND CONST(C)<高1,ISLASTBAR,DRAWNULL);
STICKLINE(中枢C2,CONST(C),低1,0,0),COLORYELLOW;
DRAWLINE(中枢C1=1,CONST(C),中枢C2=1,CONST(C),0),DOTLINE,COLORYELLOW;
DRAWLINE(中枢C1=1,低1,中枢C2=1,低1,0),COLORYELLOW;
{成立}
中枢CC1:=IF(三角型收敛A AND CONST(C)>=高1,DB2,DRAWNULL);
STICKLINE(中枢CC1,高1,低1,0,0),COLORYELLOW;
中枢CC2:=IF(三角型收敛A AND CONST(C)>=高1,ISLASTBAR,DRAWNULL);
STICKLINE(中枢CC2,高1,低1,0,0),COLORYELLOW;
DRAWLINE(中枢CC1=1,高1,中枢CC2=1,高1,0),COLORYELLOW;
DRAWLINE(中枢CC1=1,低1,中枢CC2=1,低1,0),COLORYELLOW;
三角型收敛B:=低1>低2 AND 高1<高2 AND DA1>A1 AND A2>DA1 AND DA2>A2 AND CONST(C)<高1;
中枢D1:=IF(三角型收敛B AND CONST(C)>低1,B2,DRAWNULL);
STICKLINE(中枢D1,CONST(C),高1,0,0),COLORLICYAN;
中枢D2:=IF(三角型收敛B AND CONST(C)>低1,ISLASTBAR,DRAWNULL);
STICKLINE(中枢D2,CONST(C),高1,0,0),COLORLICYAN;
DRAWLINE(中枢D1=1,高1,中枢D2=1,高1,0),COLORLICYAN;
DRAWLINE(中枢D1=1,CONST(C),中枢D2=1,CONST(C),0),DOTLINE,COLORLICYAN;
{成立}
中枢DC1:=IF(三角型收敛B AND CONST(C)<=低1,B2,DRAWNULL);
STICKLINE(中枢DC1,高1,低1,0,0),COLORLICYAN;
中枢DC2:=IF(三角型收敛B AND CONST(C)<=低1,ISLASTBAR,DRAWNULL);
STICKLINE(中枢DC2,高1,低1,0,0),COLORLICYAN;
DRAWLINE(中枢DC1=1,高1,中枢DC2=1,高1,0),COLORLICYAN;
DRAWLINE(中枢DC1=1,低1,中枢DC2=1,低1,0),COLORLICYAN;

PS:有很多股友向我反映,让我分享些股票的学习资料,为了更好的为股友们分享更多有用的资料,特用另一个小号进行分享,每天同步分享一些不错的资料,力争每天学习一点点,进步一点点,为股友们的股市长虹添砖加瓦!

 

长按识别二维码,进行关注,获取最新文章





标签 中枢REF三角型CONSTBARSLAST

声明:
1. 版权归原作者“通达信指标公式”所有, 本文转载目的在于 股票财经 爱好者个人学习使用,并不代表吉发网赞同其观点和对其真实性负责。如有侵权行为,请联系站长(webmaster@666888.net.cn),站长会尽最大努力及时删除。
2. 吉发网不提供在线交流(评论)功能,如喜欢作者的文章请点击 关注作者 扫描二维码关注"通达信指标公式"后,与作者交流留言。
3. 如文章出现QQ号、QQ群、微信号、微信群,请仔细甄别,不要轻信所谓NB的战法、NB的讲师、股票推荐、不收任何费用、万人建仓等蛊惑性描述,如遭到财产损失,不要犹豫立即报警!立即报警!立即报警!
4. 欢迎推荐或自荐优秀股市财经金融公众号加入吉发网, 既可以涨粉,又能帮助股票财经爱好者学习成长,多有意义啊^_^。
5. 吉发网不接受广告合作,不接受链接交换,相关邮件一律不回!



技术指标最新文章列表

















相关文章列表


昨日热门文章

本周热门文章

本月热门文章

股票标签云


炒股知识大全