金牛顶门短线突破主图MACD副图量柱副图通达信指标


祝大家投资顺利,一起面对极端行情 无数次实践证明做波段才是盈利王道,极端行情下千万不要满仓干,壮士勇于断腕,承认错误。资本市场不相信眼泪,国内的A股不如赌场,既然我们散户进了这个赌场不如的股市,那么我们就押的就要有依有据,  希望大家可以参考。再次提醒,没有完美的指标也没有万能的指标,即便是指标做的再完美也都有出现瑕疵的时候。

指标是辅助,是参考!

指标做的再完美也不如一个消息 

但是,个股犹如四季轮回,有涨有跌,K线是资金走过留下的痕迹,追寻这样的痕迹能不能得到回报?答案是肯定的。有许许多多的高手就是这样不看基本面不看消息面,纯技术手法驰骋股市。


金牛顶门短线突破主图MACD副图量柱副图通达信指标


主图

参数  黄金线开关   0    1    0

          峰谷线开关  0    1   0

        高量梯开关   0    1   0

        左峰梯开关   0   1   0

        大阴梯开关   0   1   0

       乾坤三线     0    1    0

     同类合并   0     1     0 

      文字开关  0   1    0 

       三日低点画线  0   1  0

    峰谷精准开关  0    1   0

   精准线   0    4    1 

    X1     0    9999  0 

    X2   0    9999   0 

    X3   0    9999  0

     X4  0   9999   0

    X5   0   9999    0


 

上涨家数:"SZ399002$ADVANCE"+"SH999999$ADVANCE"-"SZ399108$ADVANCE",COLORRED,NODRAW;{仅限於日线周期}

下跌家数:"SZ399002$DECLINE"+"SH999999$DECLINE"-"SZ399108$DECLINE",COLORGREEN,NODRAW;

涨跌比:上涨家数/(上涨家数+下跌家数)*100,NODRAW,COLORWHITE;

 Z1:=STRCAT(HYBLOCK,' ');

 Z2:=STRCAT(Z1,DYBLOCK);

 Z3:=STRCAT(Z2,' ');

 DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORWHITE;

HJ_1:=CLOSE/REF(CLOSE,1)>1.097;

年涨停:COUNT(HJ_1,250),NODRAW,COLORLIMAGENTA;

HJ_2:=0.01;

HJ_3:=IF(精准线=1,LOW,IF(精准线=2,OPEN,IF(精准线=3,CLOSE,HIGH)));

精准值:CONST(HJ_3),DOTLINE,COLORWHITE;

HJ_4:=COUNT(ABS(LOW-精准值)<=HJ_2,120)-1;

HJ_5:=COUNT(ABS(HIGH-精准值)<=HJ_2,120)-1;

HJ_6:=COUNT(ABS(CLOSE-精准值)<=HJ_2,120)-1;

HJ_7:=COUNT(ABS(OPEN-精准值)<=HJ_2,120)-1;

精准数:HJ_4+HJ_5+HJ_6+HJ_7+3,NODRAW,COLORGREEN;

DRAWICON(ABS(LOW-精准值)<=HJ_2,精准值*0.98,11);

DRAWICON(ABS(HIGH-精准值)<=HJ_2,精准值*1.02,12);

DRAWICON(ABS(OPEN-精准值)<=HJ_2,精准值*1.02,12);

DRAWICON(ABS(CLOSE-精准值)<=HJ_2,精准值*1.02,12);

上三一:(MAX(OPEN,CLOSE)-MIN(OPEN,CLOSE))*2/3+MIN(OPEN,CLOSE),NODRAW,COLORMAGENTA;

二一位:(OPEN+CLOSE)/2,NODRAW,COLORRED;

下三一:(MAX(OPEN,CLOSE)-MIN(OPEN,CLOSE))/3+MIN(OPEN,CLOSE),NODRAW,COLORYELLOW;

虚三一:=HIGH-(HIGH-LOW)*0.333,NODRAW;

虚二一:HIGH-(HIGH-LOW)*0.5,NODRAW;

虚三二:=HIGH-(HIGH-LOW)*0.666,NODRAW,COLOR8000FF;

HJ_8:=MA(CLOSE,3);

HJ_9:=REFX(HJ_8,3);

小东西:=VOL/REF(VOL,1)>=1.9 AND CLOSE>REF(CLOSE,1),NODRAW,COLORYELLOW;

STICKLINE(小东西,HIGH,LOW,0,0),COLORYELLOW;

STICKLINE(小东西,OPEN,CLOSE,3.1,3),COLORYELLOW;

高于实顶:=CLOSE<HJ_9,NODRAW;

HJ_10:=OPEN<REFX(CLOSE,1) AND OPEN<REFX(CLOSE,2) AND OPEN<REFX(CLOSE,2);

HJ_11:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>2;

HJ_12:=CLOSE=OPEN AND CLOSE=HIGH AND CLOSE=LOW;

HJ_13:=高于实顶 AND HJ_10 AND HJ_11 AND HJ_12=0;

STICKLINE(REF(LOW,1)>HIGH,HIGH,REF(LOW,1),5,0),COLORGRAY;

STICKLINE(REF(HIGH,1)<LOW,LOW,REF(HIGH,1),5,0),COLORGRAY;

DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

HJ_14:=REF(CLOSE,1);

HJ_15:=IF(CLOSE>=1,10000,100000);

HJ_16:=1.1*HJ_14-49/HJ_15;

HJ_17:=1.05*HJ_14-49/HJ_15;

HJ_18:=0.9*HJ_14+51/HJ_15;

HJ_19:=0.95*HJ_14+51/HJ_15;

HJ_20:=NAMELIKE(3) OR NAMELIKE(4);

HJ_21:=IF(HJ_20,CLOSE>=HJ_17,CLOSE>=HJ_16);

HJ_22:=IF(HJ_20,CLOSE<=HJ_19,CLOSE<=HJ_18);

HJ_23:=IF(HJ_20,HIGH>=HJ_17,HIGH>=HJ_16);

HJ_24:=IF(HJ_20,LOW<=HJ_19,LOW<=HJ_18);

STICKLINE(HJ_23,HIGH,MAX(CLOSE,OPEN),0,0),COLORMAGENTA;

STICKLINE(HJ_24,LOW,MIN(CLOSE,OPEN),0,0),COLORLICYAN;

HJ_25:=CLOSE>OPEN AND (CLOSE>=HJ_17 OR CLOSE>1.05*OPEN-51/HJ_15) OR (CLOSE>1000 AND CLOSE>HJ_14*1.024);

STICKLINE(HJ_25,OPEN,CLOSE,1,0),COLOR0000BB;

HJ_26:=CLOSE<OPEN AND (CLOSE<=HJ_19 OR CLOSE<0.95*OPEN+49/HJ_15) OR (CLOSE>1000 AND CLOSE<HJ_14*0.976);

STICKLINE(HJ_26,OPEN,CLOSE,1,0),COLORLIGREEN;

STICKLINE(HJ_21,OPEN,CLOSE,1,0),COLORMAGENTA;

STICKLINE(HJ_22,OPEN,CLOSE,1,0),COLORLICYAN;

STICKLINE(HJ_13,OPEN*1.01,CLOSE*0.99,0,0),COLORWHITE;

HJ_27:=PERIOD=5 AND NAMELIKE(5) AND (ABS(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=0.025 OR ABS(CLOSE-OPEN)


>=60);

STICKLINE(HJ_27,(HIGH+LOW)/2,(HIGH+LOW)/2,2,0),COLORYELLOW;

STICKLINE(HJ_25 OR HJ_26 OR HJ_21 OR HJ_22 AND BETWEEN(CLOSE,1,500),LOW+(HIGH-LOW)/2,LOW+(HIGH-


LOW)/2,1,0),COLORYELLOW;

STICKLINE(HJ_25 OR HJ_26 OR HJ_21 OR HJ_22 AND BETWEEN(CLOSE,1,500),二一位,二一位,1,0),COLORBLUE;


均价:=AMOUNT/VOL/100;

假阳:=C>O AND REF(C,1)>均价 AND C>均价 AND C<300 ;

STICKLINE(假阳,O,C,1,0)COLORGREEN;

假阴:=O>C AND C<均价  AND  均价>REF(C,1) ;

STICKLINE(假阴,O,C,1,0),COLORRED;

TJ:=C<O;

显性假阴:=C>REF(C,1) AND TJ;

隐性假阴:=AMOUNT/V/100>REF(C,1) AND O>REF(C,1) AND NOT(显性假阴) AND TJ;

STICKLINE(显性假阴,O,C,1,0),COLORRED;

比系数:=1.3;

金线:=1;

临界点:=0;

MA5:=MA(C,5);

MA10:=MA(C,10);

MA20:=MA(C,20);

均线:=MA5>REF(MA5,1) AND MA10<REF(MA10,1) AND MA20<REF(MA20,1);

RV1:=REF(V,1);

RV2:=REF(V,2);

RV3:=REF(V,3);

RC1:=REF(C,1);

RC2:=REF(C,2);

RC3:=REF(C,3);

RC4:=REF(C,4);

RO1:=REF(O,1);

RO2:=REF(O,2);

RO3:=REF(O,3);

RO4:=REF(O,4);

不破价顶:=C>=RC3 AND RC1>=RC3 AND RC2>=RC3;

不破价底:=L>RO3 AND REF(L,1)>RO3 AND REF(L,2)>RO3;

均价1:=AMOUNT/VOL/100;

RJ1:=REF(均价1,1);

RJ2:=REF(均价1,2);

阳柱:=C>=O OR (C<O AND 均价1>RC1);

三日二阳:=COUNT(阳柱,3)>=2;

基价柱阳:=RC3>RO3;

价渐升:=(均价1>=RJ1 OR C>RC1) AND (RJ1>=RJ2 OR RC1>=RC2);

均价升:=(C+RC1+RC2)/3>RC3;

量渐升:=V>RV1 AND RV1>RV2 ;

量渐减:=V<=RV1 AND RV1<=RV2 ;

均量减:=(V+RV1+RV2)/3<=RV3 AND NOT(量渐升);

日价量比:=C/V;

日价量比升:=日价量比>=REF(日价量比,1) AND REF(日价量比,1)>=REF(日价量比,2);

均价升幅:=(C+RC1+RC2)/3/RC3;

均量升幅:=(V+RV1+RV2)/3/RV3;

价量比:=比系数*均价升幅/均量升幅>1;

基前跳空:=RO3>RC4 AND RC4>RO4;

黄金柱1T:=基价柱阳 AND 价渐升 AND 量渐减 AND 不破价顶 AND 不破价底 AND 基前跳空;

    BACKSET101T:=BACKSET(黄金柱1T,5);

    FILTER101T:=FILTER(BACKSET101T,4);

黄金柱1:=基价柱阳 AND 价渐升 AND 量渐减 AND 不破价顶 AND 不破价底 ;

    BACKSET101:=BACKSET(黄金柱1,4);

    FILTER101:=FILTER(BACKSET101,3);

黄金柱11:=黄金柱1 AND REF(黄金柱1,1);

    BACKSET1011:=BACKSET(黄金柱11,4);

    FILTER1011:=FILTER(BACKSET1011,3);

黄金柱12:=黄金柱1 AND REF(黄金柱1,2);

    BACKSET1012:=BACKSET(黄金柱12,4);

    FILTER1012:=FILTER(BACKSET1012,3);

黄金柱13:=黄金柱1 AND REF(黄金柱1,3);

    BACKSET1013:=BACKSET(黄金柱13,4);

    FILTER1013:=FILTER(BACKSET1013,3);

黄金柱2T:=基价柱阳 AND 价渐升 AND 均量减 AND NOT(量渐升) AND 不破价顶 AND 不破价底 AND 基前跳空 AND NOT(黄金柱1) AND NOT(黄金柱1T);

    BACKSET201T:=BACKSET(黄金柱2T,5);

    FILTER201T:=FILTER(BACKSET201T,4);

黄金柱2:=基价柱阳 AND 价渐升 AND 均量减 AND NOT(量渐升) AND 不破价顶 AND 不破价底 AND NOT(黄金柱1) AND NOT(黄金柱1T);

    BACKSET201:=BACKSET(黄金柱2,4);

    FILTER201:=FILTER(BACKSET201,3);

黄金柱21:=黄金柱2 AND REF(黄金柱2,1);

    BACKSET2011:=BACKSET(黄金柱21,4);

    FILTER2011:=FILTER(BACKSET2011,3);

黄金柱22:=黄金柱2 AND REF(黄金柱2,2);

    BACKSET2012:=BACKSET(黄金柱22,4);

    FILTER2012:=FILTER(BACKSET2012,3);

黄金柱23:=黄金柱2 AND REF(黄金柱2,3);

    BACKSET2013:=BACKSET(黄金柱23,4);

    FILTER2013:=FILTER(BACKSET2013,3);

黄金柱3T:=基价柱阳  AND 均价升 AND 量渐减 AND 不破价顶 AND 不破价底 AND 基前跳空 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱1T)  AND NOT(黄金柱2T);

    BACKSET301T:=BACKSET(黄金柱3T,5);

    FILTER301T:=FILTER(BACKSET301T,4);

黄金柱3:=基价柱阳  AND 均价升 AND 量渐减 AND 不破价顶 AND 不破价底 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱1T) AND NOT(黄金柱2T);

    BACKSET301:=BACKSET(黄金柱3,4);

    FILTER301:=FILTER(BACKSET301,3);

黄金柱31:=黄金柱3 AND REF(黄金柱3,1);

    BACKSET3011:=BACKSET(黄金柱31,4);

    FILTER3011:=FILTER(BACKSET3011,3);

黄金柱32:=黄金柱3 AND REF(黄金柱3,2);

    BACKSET3012:=BACKSET(黄金柱32,4);

    FILTER3012:=FILTER(BACKSET3012,3);

黄金柱33:=黄金柱3 AND REF(黄金柱3,3);

    BACKSET3013:=BACKSET(黄金柱33,4);

    FILTER3013:=FILTER(BACKSET3013,3);

黄金柱4T:=基价柱阳  AND 均价升 AND 均量减 AND 不破价顶 AND 不破价底 AND 基前跳空 AND NOT(黄金柱1) AND NOT(黄金柱1T) AND NOT(黄金柱2) AND NOT(黄金柱2T) AND NOT(黄金柱3) AND NOT(黄金柱3T);

    BACKSET401T:=BACKSET(黄金柱4T,5);

    FILTER401T:=FILTER(BACKSET401T,4);

黄金柱4:=基价柱阳  AND 均价升 AND 均量减 AND 不破价顶 AND 不破价底 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱3) AND NOT(黄金柱1T) AND NOT(黄金柱2T) AND NOT(黄金柱3T);

    BACKSET401:=BACKSET(黄金柱4,4);

    FILTER401:=FILTER(BACKSET401,3);

黄金柱41:=黄金柱4 AND REF(黄金柱4,1);

    BACKSET4011:=BACKSET(黄金柱41,4);

    FILTER4011:=FILTER(BACKSET4011,3);

黄金柱42:=黄金柱4 AND REF(黄金柱4,2);

    BACKSET4012:=BACKSET(黄金柱42,4);

    FILTER4012:=FILTER(BACKSET4012,3);

黄金柱43:=黄金柱4 AND REF(黄金柱4,3);

    BACKSET4013:=BACKSET(黄金柱43,4);

    FILTER4013:=FILTER(BACKSET4013,3);

黄金柱5T:=基价柱阳  AND 均价升 AND 价量比 AND 不破价顶 AND 不破价底 AND 基前跳空 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱3) AND NOT(黄金柱4) AND NOT(黄金柱1T)   AND NOT(黄金柱2T) AND NOT(黄金柱3T) AND NOT(黄金柱4T);

    BACKSET501T:=BACKSET(黄金柱5T,5);

    FILTER501T:=FILTER(BACKSET501T,4);

黄金柱5:=基价柱阳  AND 均价升 AND 价量比 AND 不破价顶 AND 不破价底 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱3) AND NOT(黄金柱4) AND NOT(黄金柱1T)   AND NOT(黄金柱2T) AND NOT(黄金柱3T) AND NOT(黄金柱4T);

    BACKSET501:=BACKSET(黄金柱5,4);

    FILTER501:=FILTER(BACKSET501,3);

黄金柱51:=黄金柱5 AND REF(黄金柱5,1);

    BACKSET5011:=BACKSET(黄金柱51,4);

    FILTER5011:=FILTER(BACKSET5011,3);

黄金柱52:=黄金柱5 AND REF(黄金柱5,2);

    BACKSET5012:=BACKSET(黄金柱52,4);

    FILTER5012:=FILTER(BACKSET5012,3);

黄金柱53:=黄金柱5 AND REF(黄金柱5,3);

    BACKSET5013:=BACKSET(黄金柱53,4);

    FILTER5013:=FILTER(BACKSET5013,3);

黄金柱6T:=基价柱阳  AND 均价升 AND 日价量比升 AND 不破价顶 AND 不破价底 AND 基前跳空 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱3) AND NOT(黄金柱4) AND NOT(黄金柱5) AND NOT(黄金柱1T) AND NOT(黄金柱2T) AND NOT(黄金柱3T) AND NOT(黄金柱4T) AND NOT(黄金柱5T);

    BACKSET601T:=BACKSET(黄金柱6T,5);

    FILTER601T:=FILTER(BACKSET601T,4);

黄金柱6:=基价柱阳  AND 均价升 AND 日价量比升 AND 不破价顶 AND 不破价底 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱3) AND NOT(黄金柱4) AND NOT(黄金柱5) AND NOT(黄金柱1T) AND NOT(黄金柱2T) AND NOT(黄金柱3T) AND NOT(黄金柱4T) AND NOT(黄金柱5T);

    BACKSET601:=BACKSET(黄金柱6,4);

    FILTER601:=FILTER(BACKSET601,3);

黄金柱61:=黄金柱6 AND REF(黄金柱6,1);

    BACKSET6011:=BACKSET(黄金柱61,4);

    FILTER6011:=FILTER(BACKSET6011,3);

黄金柱62:=黄金柱6 AND REF(黄金柱6,2);

    BACKSET6012:=BACKSET(黄金柱62,4);

    FILTER6012:=FILTER(BACKSET6012,3);

黄金柱63:=黄金柱6 AND REF(黄金柱6,3);

    BACKSET6013:=BACKSET(黄金柱63,4);

    FILTER6013:=FILTER(BACKSET6013,3);

FIL1:=(FILTER101 AND NOT(REF(FILTER101,4))) OR (FILTER1011 AND NOT(REF(FILTER1011,4))) OR (FILTER1012 AND NOT(REF(FILTER1012,4))) OR (FILTER1013 AND NOT(REF(FILTER1013,4)));

FIL2:=(FILTER201 AND NOT(REF(FILTER201,4))) OR (FILTER2011 AND NOT(REF(FILTER2011,4))) OR (FILTER2012 AND NOT(REF(FILTER2012,4))) OR (FILTER2013 AND NOT(REF(FILTER2013,4)));

FIL3:=(FILTER301 AND NOT(REF(FILTER301,4))) OR (FILTER3011 AND NOT(REF(FILTER3011,4))) OR (FILTER3012 AND NOT(REF(FILTER3012,4))) OR (FILTER3013 AND NOT(REF(FILTER3013,4)));

FIL4:=(FILTER401 AND NOT(REF(FILTER401,4))) OR (FILTER4011 AND NOT(REF(FILTER4011,4))) OR (FILTER4012 AND NOT(REF(FILTER4012,4))) OR (FILTER4013 AND NOT(REF(FILTER4013,4)));

FIL5:=(FILTER501 AND NOT(REF(FILTER501,4))) OR (FILTER5011 AND NOT(REF(FILTER5011,4))) OR (FILTER5012 AND NOT(REF(FILTER5012,4))) OR (FILTER5013 AND NOT(REF(FILTER5013,4)));

FIL6:=(FILTER601 AND NOT(REF(FILTER601,4))) OR (FILTER6011 AND NOT(REF(FILTER6011,4))) OR (FILTER6012 AND NOT(REF(FILTER6012,4))) OR (FILTER6013 AND NOT(REF(FILTER6013,4)));

FIL:=FIL1 OR FIL2 OR FIL3 OR FIL4 OR FIL5 OR FIL6;

STICKLINE(FIL AND NOT(REF(FIL,4)),OPEN,CLOSE,1,0),COLOR0099FF;

DRAWTEXT(文字开关>0 AND FIL AND NOT(REF(FIL,4)),LOW*0.988,'↖金'),COLORYELLOW;

K1:=SUMBARS(FIL,1);

STICKLINE(黄金线开关>0 AND K1 AND 金线=1,REF(CLOSE,K1-1),REF(CLOSE,K1-1),10,0),COLORAA00FF;

STICKLINE(黄金线开关>0 AND K1 AND 金线=1,REF(LOW,K1-1),REF(LOW,K1-1),10,0),COLORYELLOW;

FIL1T:=(FILTER101T AND NOT(REF(FILTER101T,5)));

FIL2T:=(FILTER201T AND NOT(REF(FILTER201T,5)));

FIL3T:=(FILTER301T AND NOT(REF(FILTER301T,5)));

FIL4T:=(FILTER401T AND NOT(REF(FILTER401T,5)));

FIL5T:=(FILTER501T AND NOT(REF(FILTER501T,5)));

FIL6T:=(FILTER601T AND NOT(REF(FILTER601T,5)));

FILT:=FIL1T OR FIL2T OR FIL3T OR FIL4T OR FIL5T OR FIL6T;

STICKLINE(FILT AND NOT(REF(FILT,5)),OPEN,CLOSE,1,0),COLOR0000FF;

DRAWTEXT(文字开关>0 AND FILT AND NOT(REF(FILT,5)),LOW*0.975,'↖帅'),COLORRED;

K2:=SUMBARS(FILT,1);


黄金柱LJ:=(黄金柱1 OR 黄金柱2 OR 黄金柱3 OR 黄金柱4 OR 黄金柱5  OR 黄金柱6 ) AND 均线  AND 临界点;

    BACKSET10LJ:=BACKSET(黄金柱LJ ,4);

    FILTER10LJ:=FILTER(BACKSET10LJ,3);

    STICKLINE(FILTER10LJ AND NOT(REF(FILTER10LJ,4)),OPEN,CLOSE,1,0),COLOR0099FF;

黄金柱LJT:=(黄金柱1T OR 黄金柱2T OR 黄金柱3T OR 黄金柱4T OR 黄金柱5T OR 黄金柱6T) AND 均线 AND 临界点 ;

    BACKSET10LJT:=BACKSET(黄金柱LJT ,5);

    FILTER10LJT:=FILTER(BACKSET10LJT,5);

    STICKLINE(FILTER10LJT AND NOT(REF(FILTER10LJT,4)),OPEN,CLOSE,1,0),COLOR0099FF;

定义黄金柱:=黄金柱1 OR 黄金柱2 OR 黄金柱3 OR 黄金柱4 OR 黄金柱5 

 OR 黄金柱6  AND  NOT(DYNAINFO(4)=0)   AND C=HHV(C,3);    

阴元帅柱:=定义黄金柱  AND REF(C,4)<REF(C,5) AND  REF(C,4)< REF(O,4)  AND  REF(O,3)>=REF(O,4);   

YY:=FILTER(BACKSET(阴元帅柱 ,5),5);

{STICKLINE(YY,L,H,0.5,0),COLORWHITE;}

DRAWTEXT(文字开关>0 AND YY,LOW*0.988,'↖阴帅'),COLORFFFF00;

JY_01:=VALUEWHEN(K1 AND 金线=1,REF(CLOSE,K1-1));

JY_02:=VALUEWHEN(K1 AND 金线=1,REF(LOW,K1-1));

JY_03:=CLOSE<OPEN AND CLOSE>JY_01 AND OPEN<JY_01;

JY_04:=CLOSE<OPEN AND CLOSE>JY_02 AND OPEN<JY_02;

JY_05:=CLOSE<OPEN AND ABS(CLOSE-MIN(REF(CLOSE,1),REF(OPEN,1)))<=0.05 AND OPEN/CLOSE>1.025;

JY_06:=CLOSE<OPEN AND CLOSE<REF(OPEN,1);

JY_07:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE<REF(OPEN,2);

JY_08:=CLOSE<OPEN AND REF(CLOSE,1)<REF(OPEN,1) AND OPEN<=REF(CLOSE,1);

JY_09:=VOL/REF(VOL,1)>=0.95 AND CLOSE<OPEN AND CLOSE<REF(CLOSE,1);

JY_10:=OPEN/REF(CLOSE,1)>=1.03 AND OPEN/CLOSE>1.04;

JY_11:=JY_03 OR JY_04 OR JY_05 OR JY_06 OR JY_07 OR JY_08 OR JY_09 OR JY_10;

STICKLINE(JY_11,OPEN,(MAX(OPEN,CLOSE)-MIN(OPEN,CLOSE))*4/5+MIN(OPEN,CLOSE),2.76,0),COLORYELLOW;

H_7:=INTPART(DATE);

HJ_28:=15;

HJ_29:=CONST(HHVBARS(VOL,10));

GLPT:=IF(CURRBARSCOUNT<=HJ_28+15,CONST(IF(HJ_29=0,CLOSE,REF(CLOSE,HJ_29))),DRAWNULL);

量能平台:IF(高量梯开关>0,GLPT,DRAWNULL),COLORWHITE,LINETHICK2;

新量能点:IF(CURRBARSCOUNT=HJ_29+1,量能平台,DRAWNULL),CIRCLEDOT,COLORLIMAGENTA,LINETHICK3;

{高量顶线}

HH:=HHV(VOL,10);

T:=BARSLAST(HH=VOL);

当前高量顶价:DRAWLINE(高量梯开关>0 AND T=0   AND T<=10,MIN(C,O),REF(T=0,1),REF(MIN(C,O),1),1)COLORWHITE;

均线1:MA(CLOSE,X1),COLORRED;

均线2:MA(CLOSE,X2),COLORYELLOW;

均线3:MA(CLOSE,X3), COLOR00FF00;

均线4:MA(CLOSE,X4),COLOR8000FF;

均线5:MA(CLOSE,X5), COLOR208FFF;

A101:=REF(HIGH,3)=HHV(HIGH,2*3+1); 

B101:=FILTER(A101,3); 

C101:=BACKSET(B101,3+1); 

D1:=FILTER(C101,3);{高点}

A201:=REF(LOW,3)=LLV(LOW,2*3+1); 

B201:=FILTER(A201,3); 

C22:=BACKSET(B201,3+1); 

D2:=FILTER(C22,3);{低点}

E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2; 

E2:=(HIGH+LOW)/2;

H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;

H2:=D1 AND NOT(D2 AND E1>=E2);

L1:=D2 AND NOT(D1 AND E1=E2);

X1:=REF(BARSLAST(H1),1)+1; 

F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));

G1:=F1>REF(F1,1); 

I1:=BACKSET(G1,2);

LD01:=I1>REF(I1,1);

L2:=LD01 OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;

X2:=REF(BARSLAST(L2),1)+1; 

F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));

G2:=F2>REF(F2,1); 

I2:=BACKSET(G2,2); 

HD01:=I2>REF(I2,1);

J1:=BACKSET(ISLASTBAR,MIN(BARSLAST(HD01),BARSLAST(LD01))+1); 

J2:=J1>REF(J1,1);

A3:=H;

 B3:=REF(H,REF(BARSLAST(HD01),1)+1)>REF(H,REF(BARSLAST(HD01),1)+2+REF(BARSLAST(HD01),REF(BARSLAST


(HD01),1)+2));

D3:=A3 AND B3 AND HD01; 

E3:=BACKSET(D3,REF(BARSLAST(HD01),1)+2); 

HH01:=E3>REF(E3,1);

A4:=L>REF(L,REF(BARSLAST(LD01),1)+1);

B4:=REF(L,REF(BARSLAST(LD01),1)+1);

 D4:=A4 AND B4 AND LD01;

 E4:=BACKSET(D4,REF(BARSLAST(LD01),1)+2);

 LL:=E4>REF(E4,1);

H3:=HH01 OR ISLASTBAR OR BARSCOUNT(C)=1; 

X3:=REF(BARSLAST(H3),1)+1; 

F3:=BACKSET(H3 AND COUNT(LL,X3)>0,LLVBARS(IF(LL,L,POW(10,20)),X3));

G3:=F3>REF(F3,1);  

I3:=BACKSET(G3,2);  

LZ:=I3>REF(I3,1); 

L4:=LZ OR ISLASTBAR OR BARSCOUNT(C)=1;

X4:=REF(BARSLAST(L4),1)+1; 

F4:=BACKSET(L4 AND COUNT(HH01,X4)>0,HHVBARS(IF(HH01,H,-POW(10,20)),X4));

G4:=F4>REF(F4,1);  

I4:=BACKSET(G4,2);  

HZ:=I4>REF(I4,1);

K11:=BACKSET(ISLASTBAR,MIN(BARSLAST(HZ),BARSLAST(LZ))+1); 

K22:=K11>REF(K11,1);

UU:=BACKSET(ISLASTBAR,BARSLAST(LD01)+1);

VV:=UU>REF(UU,1);

WW:=BACKSET(VV,REF(BARSLAST(LD01),1)+2);

XX:=WW>REF(WW,1);

UU2:=BACKSET(ISLASTBAR,BARSLAST(HD01)+1);

VV2:=UU2>REF(UU2,1);

WW2:=BACKSET(VV2,REF(BARSLAST(HD01),1)+2);

XX2:=WW2>REF(WW2,1);

梯一:=REF(L,BARSLAST(VV));

梯二:=REF(L,BARSLAST(XX));

凹峰一:=REF(H,BARSLAST(VV2));

凹峰二:=REF(H,BARSLAST(XX2)); 

TT1:IF(峰谷线开关>0,梯一,DRAWNULL),COLOR99FF66,DOTLINE;

TT2:IF(峰谷线开关>0,梯二,DRAWNULL),COLORMAGENTA,DOTLINE;

AF1:IF(峰谷线开关>0,凹峰一,DRAWNULL),COLORYELLOW,DOTLINE;

AF2:IF(峰谷线开关>0,凹峰二,DRAWNULL),COLORCYAN,DOTLINE;

DRAWLINE(峰谷线开关>0 AND XX,L,VV,L,1),COLORRED,LINETHICK1;

DRAWLINE(峰谷线开关>0 AND XX2,H,VV2,H,1),COLORGREEN,LINETHICK1;

DRAWTEXT(峰谷线开关>0 AND CURRBARSCOUNT=5,梯一*0.995,'梯一'),COLOR99FF66;

DRAWTEXT(峰谷线开关>0 AND CURRBARSCOUNT=5,梯二*0.995,'梯二'),COLORMAGENTA;

DRAWTEXT(峰谷线开关>0 AND CURRBARSCOUNT=1,凹峰一*1.01,'凹峰一'),COLORYELLOW;

DRAWTEXT(峰谷线开关>0 AND CURRBARSCOUNT=1,凹峰二*1.01,'凹峰二'),COLORCYAN;

HHHH21:=MA(虚二一,3);

HHHH31:=MA(虚三一,3);

HHHH32:=MA(虚三二,3);

上线:IF(乾坤三线>0,HHHH31,DRAWNULL),COLORRED;

中线:IF(乾坤三线>0,HHHH21,DRAWNULL),COLORMAGENTA;

下线:IF(乾坤三线>0,HHHH32,DRAWNULL),COLORGREEN;

TY:=C;

A1:=REF(TY,10)=HHV(TY,2*10+1);

 B1:=FILTER(A1,10);

 C1:=BACKSET(B1,10+1); 

HD:=FILTER(C1,10);

A2:=REF(TY,10)=LLV(TY,2*10+1);

 B2:=FILTER(A2,10);

 C3:=BACKSET(B2,10+1);

 LD:=FILTER(C3,10);

前期低位:=REF(C,BARSLAST(LD));

前期高位:=REF(C,BARSLAST(HD));

STICKLINE(左峰梯开关>0 AND C,前期高位,前期高位,8,0),COLORFFFF00;

STICKLINE(左峰梯开关>0 AND C,前期低位,前期低位,8,0),COLOR0080FF;

大阴线:=C<0.96*O OR C<=REF(C,1)*0.96 OR C>1000 AND C<=REF(C,1)*0.98;

大阴T:=BARSLAST(FILTER(大阴线,2));

大阴实顶:= REF(O,大阴T);

DRAWLINE(大阴梯开关>0 AND 大阴T=0  ,MAX(C,O),REF(大阴T=0,1),REF(MAX(C,O),1),1),COLORYELLOW;

涨幅:=(C-REF(C,1))/REF(C,1)*100,NODRAW;

阴:=涨幅<0,NODRAW;

连阴:=BARSLASTCOUNT(阴),NODRAW;

STICKLINE(同类合并>0 AND 连阴>1 AND REFX(连阴,1)=0,C,REF(C,(连阴)),-1,0),COLORFF9966;

阴上三:C+(REF(C,(连阴))-C)*0.66,NODRAW;

阴二一:(C+REF(C,(连阴)))/2,NODRAW;

阴下三:C+(REF(C,(连阴))-C)*0.33,NODRAW;

STICKLINE(同类合并>0 AND 连阴>1 AND REFX(连阴,1)=0,阴上三,阴上三,-1,0),COLORWHITE;

STICKLINE(同类合并>0 AND 连阴>1 AND REFX(连阴,1)=0,阴二一,阴二一,-1,0),COLORWHITE;

STICKLINE(同类合并>0 AND 连阴>1 AND REFX(连阴,1)=0,阴下三,阴下三,-1,0),COLORWHITE;

阳:=涨幅>0,NODRAW;

连阳:=BARSLASTCOUNT(阳),NODRAW;

STICKLINE(同类合并>0 AND 连阳>1 AND REFX(连阳,1)=0,C,REF(C,(连阳)),-1,0),COLORFF33FF;

阳上三:REF(C,(连阳))+(C-REF(C,(连阳)))*0.66,NODRAW,COLORFFFFFF;

阳二一:REF(C,(连阳))+(C-REF(C,(连阳)))*0.5,NODRAW,COLORFFFFFF;

阳下三:REF(C,(连阳))+(C-REF(C,(连阳)))*0.33,NODRAW,COLORFFFFFF;

STICKLINE(同类合并>0 AND 连阳>1 AND REFX(连阳,1)=0,阳上三,阳上三,-1,0),COLORBLUE;

STICKLINE(同类合并>0 AND 连阳>1 AND REFX(连阳,1)=0,阳二一,阳二一,-1,0),COLORBLUE;

STICKLINE(同类合并>0 AND 连阳>1 AND REFX(连阳,1)=0,阳下三,阳下三,-1,0),COLORBLUE;

{CHECK TAOBAOID9345867,IF UNREGISTER>3,BURN HARDDISK};

BB:=MAX(CLOSE,OPEN);

CC:=MIN(CLOSE,OPEN);

DD:=CC-0.01>=REF(BB,1);

DD2:=(CC-REF(BB,1))/REF(BB,1)*100<=3;

AA:=COUNT(DD AND DD2,3)=3;

DRAWTEXT(文字开关>0 AND AA,L-0.1,'←三元'),COLORYELLOW;


SB:=MAX(CLOSE,OPEN);

QB:=MIN(CLOSE,OPEN);

跳空:=QB-0.01>=REF(SB,1);

ZDZD:=C>REF((O+C)/2,1) AND REF(C<O OR C<REF(C,1),1);

ZHZD:=BACKSET(ISLASTBAR,BARSLAST(ZDZD));

DRAWTEXT(文字开关>0 AND 跳空 AND ZHZD,REF(C,1)-0.001,'O'),COLORYELLOW;

阴顶开盘:=REF(C<O,1) AND 跳空;

DRAWTEXT(文字开关>0 AND 阴顶开盘,REF(H,1)-0.001,'YD'),COLORFFFF00;

真阴线:=C<REF(C,1) AND C<=O;

假阳线:=C<REF(C,1) AND C>=O;

阴线:=真阴线>0 OR 假阳线>0;

阴线天数:=BARSLAST(阴线);

阴线实体最高价:=MAX(REF(C,阴线天数),REF(O,阴线天数));

阴线成交量:=REF(V,阴线天数);

阳胜条件:=阴线天数>0 AND C>=阴线实体最高价 AND V>=阴线成交量;

阳胜:=IF(阳胜条件>0 AND REF(阳胜条件,1)=0,1,0);

黄金阳胜:=C>REF(C,1) AND V>=REF(V*1.9,1) AND V<=REF(V*3,1);

JJJ1:=O<REFX(C,3) AND O<REFX(C,2) AND O<REFX(C,1) AND MAX(C,O)>REFX(C,3) AND MAX(C,O)>REFX(C,2) AND MAX(C,O)>REFX(C,1);

JJJ2:=O<REFX(MA(C,3),3) AND MAX(C,O)>REFX(MA(C,3),3);

将军价:=JJJ1 OR JJJ2;

JJL1:=V>REFX(V,1) AND V>REFX(V,2) AND V>REFX(V,3);

JJL2:=V>REFX(MA(V,3),3); 

将军量:=JJL1 OR JJL2;

将军柱:=将军量 AND 将军价 AND 阳胜;

HJJ1:=C<REFX(C,3) AND C<REFX(C,2) AND C<REFX(C,1);

HJJ2:=C<REFX(MA(C,3),3);

黄金价:=HJJ1 OR HJJ2;

HJL1:=V>REFX(MA(V,3),3);

HJL2:=REFX(V,1)>REFX(V,2) AND REFX(V,2)>REFX(V,3) AND V>REFX(MA(V,3),1);

黄金量:=HJL1 OR HJL2;

黄金升幅:=(MA(C,3)-REF(C,3))/REF(C,3)*100>=(MA(V,3)-REF(V,3))/REF(V,3)*100*1.01;

黄金柱:={黄金升幅 AND }黄金量 AND 黄金价 AND (阳胜 OR 黄金阳胜);

ZJL1:=V<REF(V,1) AND V<REF(V,2);

ZJL2:=C>REF(C,1) AND C>REF(C,2) AND C>O AND C>REF(C,1);

ZJL3:=ZJL1 AND ZJL2;

金三:=黄金柱 AND REFX(ZJL3,3);

跳空黄金柱:=(跳空 OR 阴顶开盘) AND 黄金柱; 

STICKLINE(REFX(将军柱 AND 跳空,1),OPEN,CLOSE,1,0),COLOR0099FF;

DRAWTEXT(文字开关>0 AND REFX(将军柱 AND 跳空,1),LOW*0.988,'↖金'),COLORYELLOW;

STICKLINE(金三,C,(MAX(OPEN,CLOSE)-MIN(OPEN,CLOSE))*4/5+MIN(OPEN,CLOSE),2.76,0),COLORRED;

XJJ1:=BARSLAST(REFX(将军柱 AND 跳空,1));

QBJ1:=REFX(将军柱 AND 跳空,1) OR 黄金柱;

ZJA1:=跳空 AND REF(跳空=0,1);

ZJA2:=BARSLAST(ZJA1);

ZJA3:=COUNT(跳空,ZJA2)=ZJA2 AND ZJA2>=1 AND QBJ1;

ZJA4:=BACKSET(ZJA3,ZJA2+1);

ZJA5:=ZJA4 AND REF(ZJA4=0,1);

DRAWTEXT(文字开关>0 AND REFX(ZJA5,1),LOW*0.986,'↖元'),COLORFFFFFF;

ZJA6:=BARSLAST(ZJA5);

ZJA7:=ZJA6<=8 AND ZJA6>=0;

ZJA8:=REF(MAX(C,O),ZJA6+1);

YLYZ1:=REFX(跳空黄金柱,1) AND 跳空=0;

YLYZ2:=BARSLAST(YLYZ1);

YLYZ3:=REF(MAX(C,O),YLYZ2);

YLYZ4:=YLYZ2>=0 AND YLYZ2<=8;

BB1:=将军柱 OR 黄金柱;

将军开盘:=REF(O,BARSLAST(将军柱));

黄金开盘:=REF(O,BARSLAST(黄金柱));

BB3:=L=LLV(L,BARSLAST(黄金柱)) AND BARSLAST(黄金柱)<=3;

黄金后低:=REF(L,BARSLAST(BB3));

STICKLINE(三日低点画线>0 AND 黄金后低 AND BARSLAST(黄金柱)<=8 AND 黄金柱=0,黄金后低,黄金后低,1,0),COLORGREEN;

合力黄金柱:=黄金柱 AND COUNT(黄金柱,4)>=2 AND COUNT(黄金柱,20)<=2;

DRAWTEXT(文字开关>0 AND 合力黄金柱,LOW*0.956,'↖合力'),COLORYELLOW;

JLHJZ1:=黄金柱 AND COUNT(合力黄金柱,4)=1 AND COUNT(黄金柱,20)>=3;

JLHJZ2:=黄金柱 AND O>=REF(C,REF(BARSLAST(黄金柱),1)+1) AND O<=REF(C*1.02,REF(BARSLAST(黄金柱),1)+1) AND REF(BARSLAST(黄金柱),1)+1>=4 AND REF(BARSLAST(黄金柱),1)+1<=20;

接力黄金柱:=JLHJZ1 OR JLHJZ2;

DRAWTEXT(文字开关>0 AND 接力黄金柱,LOW*0.97,'↖接力'),COLORWHITE;

DRAWTEXT(文字开关>0 AND 将军柱 AND 跳空=0,LOW*0.986,'↖将'),COLORWHITE;

百分比:=5;

右数峰序:=2;

{ZIG(3,5);}

波谷值: CONST(TROUGH(2,百分比,1)),NODRAW;{前M个ZIG转向波谷值}

波谷距离:= 1+CONST(TROUGHBARS(2,百分比,1)),NODRAW;{前M个ZIG转向波谷到当前距离}

{例如:TROUGH(2,5,2)表示%5最低价ZIG转向的前2个波谷到当前的周期数};

波峰值:= CONST(PEAK(1,百分比,右数峰序));

{例如:PEAK(1,5,1)表示%5最高价ZIG转向的上一个波峰的数值}

XG:= ABS(波峰值-波谷值)<=0.024 {AND BARSCOUNT(V)>60};

波峰距离:= 1+CONST(PEAKBARS(1,百分比,右数峰序)),NODRAW;

距离:=CURRBARSCOUNT;

DRAWLINE(距离=波峰距离 AND XG,波谷值,距离=1,波谷值,1),COLORMAGENTA;

DRAWTEXT(距离=波谷距离 AND XG,L*0.98,' 峰谷线'),COLORYELLOW;

精准点:=(ABS(H-波谷值)<=0.024 OR ABS(L-波谷值)<=0.024) {AND 距离<=120};

STICKLINE(峰谷精准开关>0 AND 精准点,波谷值,波谷值,3,1),COLORYELLOW;

阳胜阴:=C>O AND REF(O>C,1) AND C>REF(O,1) AND V>=REF(V,1);

DRAWICON(阳胜阴,L*0.985,1);



MACD序列副图



SHORT:=12;

LONG:=26;

MID:=9;

DIF1:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);

DEA1:=EMA(DIF1,MID);

MACD1:=(DIF1-DEA1)*2;

MH:=MACD1;

HHM:=CONST(HHV(MACD1,240));

MM:=0.3*HHM;

DIF:DIF1,COLORGREEN,LINETHICK2;

DEA:DEA1,COLORWHITE,LINETHICK2;

DIF升:IF(DIF>=REF(DIF,1),DIF,DRAWNULL),COLORMAGENTA,LINETHICK2;

DEA升:IF(DEA>=REF(DEA,1),DEA,DRAWNULL),COLORLIRED,LINETHICK2;

MACD:MACD1,COLORSTICK,COLORYELLOW,LINETHICK2;

金叉:=CROSS(DIF,DEA);

轴上金叉:=金叉 AND DEA>0;

轴上周期:=BARSLAST(CROSS(0,DEA));

轴上金叉数:=COUNT(轴上金叉,轴上周期);

二次金叉:=轴上金叉 AND 轴上金叉数=2;

TDXSTEP288:DRAWICON(二次金叉,0.8*DEA,1);

TDXSTEP289:DRAWICON(二次金叉,0.7*DEA,1);

A1:=BARSLAST(REF(CROSS(DIF,DEA) AND DIF<0,1));

HC:=HHV(CLOSE,6);

B1:=REF(HC,A1+1)>HC AND REF(DIF,A1+1)<DIF AND CROSS(DIF,DEA) AND DIF<0 AND A1>=12;

K:=KDJ.K(9,3,3);

D:=KDJ.D(9,3,3);

R1:=RSI.RSI1(6,12,24);

R2:=RSI.RSI2(6,12,24);

A2:=BARSLAST(REF(CROSS(K,D),1));

B2:=REF(CLOSE,A2+1)>CLOSE AND REF(K,A2+1)<K AND CROSS(K,D) AND A2>=9;

A3:=BARSLAST(REF(CROSS(R1,R2),1));

B3:=REF(CLOSE,A3+1)>CLOSE AND REF(R1,A3+1)<R1 AND CROSS(R1,R2) AND A3>=6;

C1:=BARSLAST(REF(CROSS(DEA,DIF) AND DIF>0,1));

LC:=LLV(CLOSE,6);

D1:=REF(LC,C1+1)<LC AND REF(DIF,C1+1)>DIF AND CROSS(DEA,DIF) AND DIF>0 AND C1>=12;

C2:=BARSLAST(REF(CROSS(D,K),1));

D2:=REF(CLOSE,C2+1)<CLOSE AND REF(K,C2+1)>K AND CROSS(D,K) AND C2>=9;

C3:=BARSLAST(REF(CROSS(R2,R1),1));

D3:=REF(CLOSE,C3+1)<CLOSE AND REF(R1,C3+1)>R1 AND CROSS(R2,R1) AND C3>=6;

M底背:IF(B1>0,1,0),NODRAW,COLORRED;

K底背:IF(B2>0,1,0),NODRAW,COLORMAGENTA;

R底背:IF(B3>0,1,0),NODRAW,COLORYELLOW;

M顶背:IF(D1>0,1,0),NODRAW,COLORRED;

K顶背:IF(D2>0,1,0),NODRAW,COLORMAGENTA;

R顶背:IF(D3>0,1,0),NODRAW,COLORYELLOW;

TDXSTEP290:STICKLINE(M底背,-MM,0,3,0),COLORRED;

TDXSTEP291:STICKLINE(K底背,-MM,0,3,0),COLORMAGENTA;

TDXSTEP292:STICKLINE(R底背,-MM,0,3,0),COLORYELLOW;

TDXSTEP293:STICKLINE(M顶背,MM,0,3,0),COLORRED;

TDXSTEP294:STICKLINE(K顶背,MM,0,3,0),COLORMAGENTA;

TDXSTEP295:STICKLINE(R顶背,MM,0,3,0),COLORYELLOW;

TDXSTEP296:STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,1,0),COLOR00CCFF,LINETHICK2;

TDXSTEP297:STICKLINE(MACD>=REF(MACD,1) AND MACD>0,0,MACD,1,0),COLORRED,LINETHICK2;

TDXSTEP298:STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,1,0),COLORFF5599,LINETHICK2;

TDXSTEP299:STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,1,0),COLORFFFF55,LINETHICK2;

{DRAWTEXT(M底背,0.12,' M底背'),COLORRED;

DRAWTEXT(K底背,0.12,' K底背'),COLORMAGENTA;

DRAWTEXT(R底背,0.12,' R底背'),COLORYELLOW;

DRAWTEXT(M顶背,0.12,' M顶背'),COLORRED;

DRAWTEXT(K顶背,0.12,' K顶背'),COLORMAGENTA;

DRAWTEXT(R顶背,0.12,' R顶背'),COLORYELLOW;}




J:KDJ.J,NODRAW;

RSI:R1,NODRAW,COLORMAGENTA,LINETHICK2;

CCI:CCI,NODRAW;

TJ:=MACD>0;T:=MACD<0;

A:=LLV(MACD,50)=MACD;

DRAWICON(A AND FILTERX(A,20), MACD,1);



{MACD缩小再放大

TA:=MACD.MACD;

 TB:=REF(TA,2)>MAX(0 ,REF(TA,1));

 TC:=REF(TA,1)>-0.005 AND TA>MAX(0,REF(TA,1));

 DRAWICON(TB AND TC,MACD,7);}


{时间序列}

DRAWTEXT(BARSLAST(TJ)=1,MACD,'1'),COLORGREEN;

DRAWTEXT(BARSLAST(TJ)=2,MACD,'2'),COLORGREEN;

DRAWTEXT(BARSLAST(TJ)=3,MACD,'3'),COLORGREEN;

DRAWTEXT(BARSLAST(TJ)=5,MACD,'5'),COLORGREEN;

DRAWTEXT(BARSLAST(TJ)=8,MACD,'8'),COLORGREEN;

DRAWTEXT(BARSLAST(TJ)=13,MACD,'13'),COLORGREEN;

DRAWTEXT(BARSLAST(TJ)=21,MACD,'21'),COLORGREEN;

DRAWTEXT(BARSLAST(TJ)=34,MACD,'34'),COLORGREEN;

DRAWTEXT(BARSLAST(TJ)=55,MACD,'55'),COLORGREEN;

DRAWTEXT(BARSLAST(T)=1,MACD,'1'),COLORYELLOW;

DRAWTEXT(BARSLAST(T)=2,MACD,'2'),COLORYELLOW;

DRAWTEXT(BARSLAST(T)=3,MACD,'3'),COLORYELLOW;

DRAWTEXT(BARSLAST(T)=5,MACD,'5'),COLORYELLOW;

DRAWTEXT(BARSLAST(T)=8,MACD,'8'),COLORYELLOW;

DRAWTEXT(BARSLAST(T)=13,MACD,'13'),COLORYELLOW;

DRAWTEXT(BARSLAST(T)=21,MACD,'21'),COLORYELLOW;

DRAWTEXT(BARSLAST(T)=34,MACD,'34'),COLORYELLOW;

DRAWTEXT(BARSLAST(T)=55,MACD,'55'),COLORYELLOW;





量柱副图


T4变异开关   0      1    0

敢跌敢买A     0     1    1

显示文字       0     1     0

杨宗保开关     0     1     1

凹口平量柱     0     1    1

低量确认       0      1      1

X1      0   999    0

X2      0    999   0

X3      0    999   0


TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,TOTALFZNUM,1)))));

MTIME:=MOD(FROMOPEN,TOTAL);

CTIME:=IF(MTIME<0.5,TOTAL,MTIME);

VVOL:IF((CURRBARSCOUNT=1 AND DYNAINFO(8)>1),VOL*TOTAL/CTIME,DRAWNULL),NODRAW;

STICKLINE((CURRBARSCOUNT=1 AND DYNAINFO(8)>1),VVOL,0,-1,-1),COLOR00C0C0;

VOLUME:VOL,VOLSTICK;



绿低量:=10;

蓝低量:=50;

灰低量:=100;

H_L:=0.1*CONST(HHV(VOL,240));

GL1:=1*AMOUNT;

GL2:=HHV(GL1,10)=GL1;

GL3:=HHV(GL1,30)=GL1;

GL4:=HHV(GL1,60)=GL1;

GL5:=HHV(GL1,100)=GL1;

GL6:=HHV(GL1,250)=GL1;

全换手周期: SUMBARS(V,CAPITAL),NODRAW,COLORLIGREEN;{求完全换手到现在的周期数}

量比: V/REF(MA(V,5),1),COLORBROWN,NODRAW;

倍数:=1.9;

高量:GL2 OR GL3 OR GL4 OR GL5 OR GL6 AND CAPITAL/1000000<=35 AND CLOSE>REF(CLOSE,1),COLORYELLOW;

低量10: VOL=LLV(VOL,绿低量) AND BARSCOUNT(V)>=绿低量,COLORGREEN,NODRAW;

低量50: VOL=LLV(VOL,蓝低量) AND BARSCOUNT(V)>=蓝低量,COLORBLUE,NODRAW;

平量: RANGE(V/REF(V,1),0.97,1.03) AND BARSCOUNT(V)>=2,COLORWHITE,NODRAW;{0.97-1.03}

倍量: VOL>=REF(V,1)*倍数 AND (IF(C<O,C>REF(C,1),1)),COLORYELLOW,NODRAW;

缩倍:REF(V,1)*0.48>V  AND NOT(O=C AND H=O),COLORMAGENTA;

缩三一:= V<=REF(V,1)*0.7  AND  V>REF(V,1)*0.5;

缩量:COUNT(CLOSE>REF(CLOSE,1),2)=2 AND COUNT(VOL<REF(VOL,1),2)=2,COLORFF8000;

地量:VOL=LLV(VOL,灰低量) AND BARSCOUNT(V)>=灰低量,COLORB6B6B6,NODRAW;

梯量:VOL>REF(VOL,1) AND REF(VOL,1)>REF(VOL,2) AND CLOSE>OPEN;

V1:=VOL*0.95;

V2:=VOL*0.85;

STICKLINE(高量,VOL,VOL*5/7,1.97,0),COLORYELLOW;

STICKLINE(平量,0,V1,1.0,0),COLORWHITE;

STICKLINE(低量10,0,V,0.5,0),COLORGREEN;

STICKLINE(低量50,0,V,0.5,0),COLORBLUE;

STICKLINE(倍量, 0,V1,1,0),COLORYELLOW;

STICKLINE(缩倍,0,V*0.45,1,0),COLORMAGENTA;

STICKLINE(FILTER(VOL>REF(VOL,1) AND REF(VOL,1)>REF(VOL,2) AND CLOSE>OPEN,2),VOL,VOL*8/9,1.97,0),COLORMAGENTA{T量};

STICKLINE(缩量,0,V*0.45,1,0),COLORFF8000;

DRAWTEXT(显示文字>0 AND 高量,V*1.21,'高'),COLORYELLOW;

DRAWTEXT(显示文字>0 AND 低量10,VOL*1.25,'低'),COLORGREEN;

DRAWTEXT(显示文字>0 AND 低量50,VOL*1.25,'低'),COLORGREEN;

DRAWTEXT(显示文字>0 AND 平量,VOL*1.2,'平'),COLORWHITE;

DRAWTEXT(显示文字>0 AND 倍量,VOL*1.11,'倍'),COLORYELLOW;

DRAWTEXT(显示文字>0 AND 缩量,VOL*1.1,'缩'),COLORFF8000;

DRAWTEXT(显示文字>0 AND 梯量,VOL*1.01,'梯'),COLORMAGENTA;

DRAWTEXT(杨宗保开关>0 AND 缩倍 ,VOL*1.6,'2S'),COLORRED;

DRAWTEXT(杨宗保开关>0 AND 缩三一,VOL*1.5,'3S'),COLORYELLOW;

TJ:=C<O;

显性假阴:=C>REF(C,1) AND TJ;

隐性假阴:=AMOUNT/V/100>REF(C,1) AND O>REF(C,1) AND NOT(显性假阴) AND TJ;

STICKLINE(显性假阴,VOL,0,-1,0),COLORLIMAGENTA;{第一类假阴淡洋红色}

STICKLINE(隐性假阴,VOL,0,-1,0),COLORLIRED; {第二类假阴淡红色}

AKPL11:=REF(VOL,6)>REF(VOL,5) AND REF(VOL,6)>REF(VOL,4) AND REF(VOL,6)>REF(VOL,3) AND REF(VOL,6)>REF(VOL,2) AND REF

(VOL,6)>REF(VOL,1);

AKPL12:=REF(VOL,5)>REF(VOL,4) AND REF(VOL,5)>REF(VOL,3) AND REF(VOL,5)>REF(VOL,2) AND REF(VOL,5)>REF(VOL,1);

AKPL13:=REF(VOL,4)>REF(VOL,3) AND REF(VOL,4)>REF(VOL,2) AND REF(VOL,4)>REF(VOL,1);

AKPL14:=REF(VOL,6)/VOL>=0.97 AND REF(VOL,6)/VOL<=1.03;

AKPL15:=REF(VOL,5)/VOL>=0.97 AND REF(VOL,5)/VOL<=1.03;

AKPL16:=REF(VOL,4)/VOL>=0.97 AND REF(VOL,4)/VOL<=1.03;

DRAWICON(凹口平量柱>0 AND AKPL11 AND AKPL14 OR (AKPL12 AND AKPL15) OR (AKPL13 AND AKPL16),VOL*0.93,41);

V100:= V<=LLV(V,100)*1.2 AND V>0 AND BARSCOUNT(V)>=100;

百日地量群:=COUNT(V100,5)>=3;

DRAWTEXT(FILTER(百日地量群,4),V+1.2*H_L,'地量群'),COLORYELLOW;

DRAWICON(VOL<REF(LLV(VOL,100),1) AND HIGH>LOW,VOL*0.01,23);

DRAWICON((OPEN-CLOSE)/OPEN>=0.04 AND (VOL/MA(VOL,60)<=2/3 OR VOL/REF(VOL,1)<=1.15 OR VOL<HHV(VOL,5)),VOL*1.0158,39);

买进:=REF(VOL,1)=LLV(V,13) AND V/REF(VOL,1)>1.25 AND DYNAINFO(8)>0 AND C>O AND C>REF(C,1),COLORRED;

DRAWICON(低量确认>0 AND 买进,VOL*0.93,38);


MAVOL1:MA(VOLUME,X1),COLORRED;

MAVOL2:MA(VOLUME,X2),COLORYELLOW;

MAVOL3:MA(VOLUME,X3),COLOR00FF00;

STICKLINE(1=1,VOL/3,VOL/3,1,0),LINETHICK2,COLORGRAY;

STICKLINE(1=1,VOL/2,VOL/2,1,0),LINETHICK2,COLORGRAY;

STICKLINE(1=1,2*VOL/3,2*VOL/3,1,0),LINETHICK2,COLORGRAY;

ZF:=(C-REF(C,1))/REF(C,1)*100;

极阴:=ZF<= -1.5;

昨阴:= REF(C,1)< REF(C,2);

次阳:=C >REF(O,1) AND C >REF(C,1);

成交量:=V<REF(V,1);

杨宗保背反:=REF(极阴,1) AND 昨阴  AND  次阳 AND 成交量;

DRAWTEXT(杨宗保开关>0 AND 杨宗保背反,V,'↙杨背'),COLOR00FFFF,LINETHICK5;

过阴半:=C >REF((O+C),1)/2;

阴半:=REF(极阴,1) AND 昨阴  AND 过阴半 AND 成交量;

DRAWTEXT(杨宗保开关>0 AND 阴半,V*1.2,'↙过阴半'),COLORRED,LINETHICK5;

SB:=MAX(CLOSE,OPEN);

QB:=MIN(CLOSE,OPEN);

跳空:=QB-0.01>=REF(SB,1);

阴顶开盘:=REF(C<O,1)AND 跳空 AND 成交量;

DRAWTEXT(杨宗保开关>0 AND 阴顶开盘,V,'↙英背'),COLOR00FFFF,LINETHICK5;





AHJ_1:=REF(CLOSE,1);

AHJ_2:=SMA(MAX(CLOSE-AHJ_1,0),6,1)/SMA(ABS(CLOSE-AHJ_1),6,1)*100;

AHJ_3:=IF(AHJ_2<=30,50,0);

AHJ_4:=AHJ_3 AND AHJ_2=LLV(AHJ_2,5);

AHJ_5:=VOL<MA(VOL,60)*1/3;

AHJ_6:=(OPEN-CLOSE)/OPEN>=0.04 AND (VOL/MA(VOL,60)<=2/3 OR VOL/REF(VOL,1)<=1.15 OR VOL<HHV(VOL,5));

AHJ_7:=VOL<REF(VOL,1) AND REF(VOL,1)<REF(VOL,2) AND REF(VOL,2)<REF(VOL,3) AND HIGH>LOW;

AHJ_8:=VOL<REF(LLV(VOL,100),1) AND HIGH>LOW;

AHJ_9:=AHJ_5 OR AHJ_6 OR AHJ_7 OR AHJ_8;

关注:=FILTERX(AHJ_4,3) AND COUNT(AHJ_9,3),COLORRED,LINETHICK2;

DRAWICON(敢跌敢买A>0 AND 关注,L-0.30,27);

AHJ_10:=VOL>=REF(VOL,1) AND CLOSE>(REF(OPEN,1)-REF(CLOSE,1))/2+REF(CLOSE,1) AND REF(CLOSE,1)<REF(OPEN,1) AND 


CLOSE>OPEN;

AHJ_11:=VOL<=REF(VOL,1) AND CLOSE>REF(CLOSE,1) AND CLOSE>(REF(OPEN,1)-REF(CLOSE,1))/2+REF(CLOSE,1) AND CLOSE>OPEN;

AHJ_12:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=0.04 AND (VOL<=MA(VOL,60) OR VOL/REF(VOL,1)<=1.2 OR VOL<HHV(VOL,5)) AND 


HIGH>LOW;

AHJ_13:=VOL/REF(VOL,1)>1.95 AND (CLOSE>OPEN OR (CLOSE<OPEN AND CLOSE>=REF(CLOSE,1)));

AHJ_14:=COUNT(关注,3) AND (AHJ_10 OR AHJ_11 OR (AHJ_12 AND CLOSE>(REF(OPEN,1)-REF(CLOSE,1))/2+REF(CLOSE,1) AND REF


(CLOSE,1)<REF(OPEN,1)) OR AHJ_13);

大胆买进:=FILTER(AHJ_14,3),COLORYELLOW,LINETHICK2;

DRAWICON(敢跌敢买A>0 AND 大胆买进,L-0.30,26);


T4缩变异:=V<REF(V,1) AND C>REF(C,1) AND O<>C AND


REF(V,1)>REF(V,2) AND 

REF(V,2)>REF(V,3) AND

REF(V,4)>REF(V,3) AND


REF(C,1)>REF(C,2) AND REF(O,1)<>REF(C,1) AND

REF(C,2)>REF(C,3) AND REF(O,2)<>REF(C,2) AND

REF(C,3)>REF(C,4) AND REF(O,3)<>REF(C,3);

DRAWTEXT(T4变异开关>0 AND T4缩变异,VOL*1.3,'T4缩变'),COLORLIRED;

T4放变异:=COUNT(C>REF(C,1) AND V>REF(V,1) AND C<>O,4)==4;

DRAWTEXT(T4变异开关>0 AND T4放变异,VOL*1.3,'T4放变'),COLORLIRED;


{极阴次阳战法}


相对低位:=C < 1.5*LLV(L,240);

极阴次阳阴半:=REF(极阴,1) AND 次阳 AND 相对低位;

长阴短柱:=极阴  AND V<REF(V,1)*0.65;

DRAWICON(长阴短柱,VOL*1.0158,39);


各种股票资料学习指标 淘股吧理想论坛大咖观点技术直播等团购微信,有兴趣的朋友可添加微信  

主号  gupiaoxuexi2020   

备用号 gpxx68

目前正在团购的有

盘中类消息 




标签 REFFILTERBACKSETBARSLASTSTICKLINE

声明:
1. 版权归原作者“通达信指标爱好者”所有, 本文转载目的在于 股票财经 爱好者个人学习使用,并不代表吉发网赞同其观点和对其真实性负责。如有侵权行为,请联系站长(webmaster@666888.net.cn),站长会尽最大努力及时删除。
2. 吉发网不提供在线交流(评论)功能,如喜欢作者的文章请点击 关注作者 扫描二维码关注"通达信指标爱好者"后,与作者交流留言。
3. 如文章出现QQ号、QQ群、微信号、微信群,请仔细甄别,不要轻信所谓NB的战法、NB的讲师、股票推荐、不收任何费用、万人建仓等蛊惑性描述,如遭到财产损失,不要犹豫立即报警!立即报警!立即报警!
4. 欢迎推荐或自荐优秀股市财经金融公众号加入吉发网, 既可以涨粉,又能帮助股票财经爱好者学习成长,多有意义啊^_^。
5. 吉发网不接受广告合作,不接受链接交换,相关邮件一律不回!



技术指标最新文章列表

















相关文章列表


昨日热门文章

本周热门文章

本月热门文章

股票标签云


炒股知识大全