挖掘启动牛股(指标、主图 选股/预警/副图、通达信、贴图),无未来函数


祝大家投资顺利,一起面对极端行情 无数次实践证明做波段才是盈利王道,极端行情下千万不要满仓干,壮士勇于断腕,承认错误。资本市场不相信眼泪,国内的A股不如赌场,既然我们散户进了这个赌场不如的股市,那么我们就押的就要有依有据,  希望大家可以参考。再次提醒,没有完美的指标也没有万能的指标,即便是指标做的再完美也都有出现瑕疵的时候。

指标是辅助,是参考!

指标做的再完美也不如一个消息 

但是,个股犹如四季轮回,有涨有跌,K线是资金走过留下的痕迹,追寻这样的痕迹能不能得到回报?答案是肯定的。有许许多多的高手就是这样不看基本面不看消息面,纯技术手法驰骋股市。


挖掘启动牛股(指标、选股/预警/副图、通达信、贴图),无未来函数 


主图

DRAWGBK(C>O,RGB(10,0,0),RGB(0,0,0),1,2,1);

DRAWKLINE(H,O,L,C);

安全:=MA(C,30),CIRCLEDOT,COLORFF00FF;

当日成本:=IF(C>REF(C,1),(3*H+4*C+3*OPEN+2*L)/12,(2*H+4*C+3*OPEN+3*L)/12);

{板块市值业绩}

所属板块:=STRCAT('【所属板块】',STRCAT(STRCAT(STRCAT('     [行业]—',HYBLOCK),STRCAT('     [地域]—',DYBLOCK)),STRCAT('     [概念]—',GNBLOCK)));

总股本:=STRCAT(STRCAT('     总股本:',CON2STR(TOTALCAPITAL/1000000,2)),'亿');

流通盘:=STRCAT(STRCAT('     流通盘:',CON2STR(CAPITAL/1000000,2)),'亿');

全流通:=STRCAT(STRCAT('     流通比:',CON2STR(CAPITAL/TOTALCAPITAL*100,2)),'%');

市值:=STRCAT(STRCAT('     流通市值:',CON2STR((CAPITAL/1000000)*C,2)),'亿');

上市日期:=STRCAT('     上市日期: ',CON2STR(HHV((BARSCOUNT(C)=0)*(DATE+19000000),0),0));

股本市值:=STRCAT('【股本市值】',STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),上市日期));

市盈率:=STRCAT('     市盈率:',CON2STR(C/FINANCE(33),2));

市销率:=STRCAT('     市销率:',CON2STR(C/(FINANCE(20)/FINANCE(1)),2));

市净率:=STRCAT('     市净率:',CON2STR(C/FINANCE(34),2));

净资收益率:=STRCAT('     净资收益率:',CON2STR(FINANCE(33)/FINANCE(34)*100,2));

毛利率:=STRCAT('     毛利率:',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));

净利润率:=STRCAT('     净利率:',CON2STR(FINANCE(30)/FINANCE(20)*100,2));

主营利润率:=STRCAT('     主营利润率:',CON2STR(FINANCE(23)/FINANCE(20)*100,2));

当前业绩:=STRCAT('【当前业绩】',STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(市盈率,市销率),市净率),净资收益率),毛利率),净利润率),主营利润率));

DRAWTEXT_FIX(ISLASTBAR,0.005,0.02,0,所属板块),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0.005,0.07,0,股本市值),COLORMAGENTA;

DRAWTEXT_FIX(ISLASTBAR,0.005,0.12,0,当前业绩),COLORMAGENTA;

DRAWTEXT_FIX(1,0.005,0.17,0,'莸利比例:'),COLORYELLOW;

DRAWNUMBER_FIX(1,0.06,0.17,0,CONST(WINNER(C )*100)),COLORYELLOW;

DRAWNUMBER_FIX(1,0.15,0.17,0,CONST(DYNAINFO(37)*100)),COLORYELLOW;

DRAWTEXT_FIX  (1,0.12,0.17,0,'换手:'),COLORYELLOW;

DRAWNUMBER_FIX(1,0.25,0.17,0,CONST(DYNAINFO(17))),COLORYELLOW;

DRAWTEXT_FIX  (1,0.22,0.17,0,'量比:'),COLORYELLOW;

DRAWTEXT_FIX  (1,0.30,0.17,0,'涨幅:'),COLORYELLOW;

DRAWNUMBER_FIX(1,0.33,0.17,0,CONST(DYNAINFO(14)*100)),COLORYELLOW;

DRAWNUMBER_FIX(1,0.33,0.17,0,IF(CONST(DYNAINFO(14)*100)<0,CONST(DYNAINFO(14)*100),DRAWNULL)),COLORYELLOW;

X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;

X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替};

X3:=FINANCE(23)/FINANCE(10)*3.3;

X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}

X5:=FINANCE(20)/FINANCE(15)*0.999;

Z值:=X1+X2+X3+X4+X5;

预警:=IF(Z值<1.2,'重警',IF(Z值>=1.2 AND Z值<2.6,'轻警','无警'));

财务预警:=STRCAT('财务预警: ',STRCAT(预警,STRCAT('-Z值: ',CON2STR(Z值,3))));

优质资产率:=STRCAT(' 优质资产率: ',CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19),2));{理论上越大越好但不同行业有不同标准};

现金负债比:=STRCAT(' 现金负债比: ',CON2STR(FINANCE(25)/FINANCE(15),3));{缺长期负债或负债总额,理论上越大越好但不同行业有不同标准};

财务系数:=STRCAT('风险系数: ',STRCAT(STRCAT(财务预警,优质资产率),现金负债比));

DRAWTEXT_FIX(ISLASTBAR,0.005,0.23,0,财务系数),COLORGREEN;

{双龙趋势}

龙一:EMA(H,55),COLORGREEN,LINETHICK1;

龙二:EMA(L,55),COLORGREEN,LINETHICK1;

NA1:=PLOYLINE(C>龙一,龙一);

IF(C>龙一,NA1,DRAWNULL),COLORMAGENTA,LINETHICK1;

NB1:=PLOYLINE(C>龙二,龙二);

IF(C>龙二,NB1,DRAWNULL),COLORMAGENTA,LINETHICK1;

{神龙顶底}

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

DRAWICON(CROSS(J,0),L*0.999,34);

DRAWICON(CROSS(100,J),H*1.003,35);

{九转序列}

A1:=C>REF(C,4);

A2:=C<REF(C,4);

T1:=A2 AND REF(A1,1);

T2:=A2 AND REF(T1,1);

T3:=A2 AND REF(T2,1);

T4:=A2 AND REF(T3,1);

T5:=A2 AND REF(T4,1);

T6:=A2 AND REF(T5,1);

T7:=A2 AND REF(T6,1);

T8:=A2 AND REF(T7,1);

T9:=A2 AND REF(T8,1);

DRAWTEXT(T6,L*0.995,'6'),COLORGREEN;

DRAWTEXT(T7,L*0.995,'7'),COLORGREEN;

DRAWTEXT(T8,L*0.995,'8'),COLORGREEN;

DRAWTEXT(T9,L*0.995,'9'),COLORGREEN;

B1:=C<REF(C,4);

B2:=C>REF(C,4);

D1:=B2 AND REF(B1,1);

D2:=B2 AND REF(D1,1);

D3:=B2 AND REF(D2,1);

D4:=B2 AND REF(D3,1);

D5:=B2 AND REF(D4,1);

D6:=B2 AND REF(D5,1);

D7:=B2 AND REF(D6,1);

D8:=B2 AND REF(D7,1);

D9:=B2 AND REF(D8,1);

DRAWTEXT(D6,H*1.008,'6'),COLORYELLOW;

DRAWTEXT(D7,H*1.008,'7'),COLORYELLOW;

DRAWTEXT(D8,H*1.008,'8'),COLORYELLOW;

DRAWTEXT(D9,H*1.008,'9'),COLORYELLOW;

慢牛线:=EXPMEMA(当日成本,51),LINETHICK2,COLORMAGENTA;

波段高:(XMA(XMA(HIGH,30),30)-XMA(XMA(LOW,30),30))*2+XMA(XMA(HIGH,30),30),COLORWHITE,LINETHICK1;

波段低:XMA(XMA(LOW,30),30)-(XMA(XMA(HIGH,30),30)-XMA(XMA(LOW,30),30))*1.5,COLORWHITE,LINETHICK1;

波段中值:(波段高+波段低)/2,DOTLINE,COLOR909090;

IF(波段高>=REF(波段高,1),波段高,DRAWNULL),COLORRED,LINETHICK2;

IF(波段低>=REF(波段低,1),波段低,DRAWNULL),COLORRED,LINETHICK2;

IF(波段高<=REF(波段高,1),波段高,DRAWNULL),COLOR008800,LINETHICK3;

IF(波段低<=REF(波段低,1),波段低,DRAWNULL),COLOR008800,LINETHICK3;

STICKLINE(REF(LOW,1)<波段低 AND CLOSE>波段低 AND 波段高>=REF(波段高,1) AND CLOSE>OPEN,CLOSE,OPEN,(-1),0),COLORYELLOW;

STICKLINE(REF(HIGH,1)>=波段高 AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN,CLOSE,OPEN,(-1),0),COLORFF6600;

DRAWKLINE(HIGH,OPEN,LOW,CLOSE);



副图

选股


月DIF1:="MACD.DIF#MONTH"(12,26,9);

月DEA1:="MACD.DEA#MONTH"(12,26,9);

AA1:=月DIF1>月DEA1;

月M:=CROSS(AA1>REF(AA1,1),0.5);

周RSI1:="RSI.RSI1#WEEK"(9);

SY:=周RSI1>50;

共振:=CROSS(SY>REF(SY,1),0.5);

周DIF1:="MACD.DIF#WEEK"(12,26,9);

周DEA1:="MACD.DEA#WEEK"(12,26,9);

SK:=周DIF1>周DEA1;

周M:=CROSS(SY>REF(SK,1),0.5);

周K1:="KDJ.K#WEEK"(9,3,3);

周D1:="KDJ.D#WEEK"(9,3,3);

SQ:=周K1>周D1;

介入:=CROSS(SQ>REF(SQ,1),0.5);

XG:共振 AND 介入 AND 周M;


各种股票资料学习指标 淘股吧理想论坛大咖观点技术直播等团购微信,有兴趣的朋友可添加微信  

主号  gupiaoxuexi2020   




标签 STRCATREFCON2STR指标A2

声明:
1. 版权归原作者“通达信指标爱好者”所有, 本文转载目的在于 股票财经 爱好者个人学习使用,并不代表吉发网赞同其观点和对其真实性负责。如有侵权行为,请联系站长(webmaster@666888.net.cn),站长会尽最大努力及时删除。
2. 吉发网不提供在线交流(评论)功能,如喜欢作者的文章请点击 关注作者 扫描二维码关注"通达信指标爱好者"后,与作者交流留言。
3. 如文章出现QQ号、QQ群、微信号、微信群,请仔细甄别,不要轻信所谓NB的战法、NB的讲师、股票推荐、不收任何费用、万人建仓等蛊惑性描述,如遭到财产损失,不要犹豫立即报警!立即报警!立即报警!
4. 欢迎推荐或自荐优秀股市财经金融公众号加入吉发网, 既可以涨粉,又能帮助股票财经爱好者学习成长,多有意义啊^_^。
5. 吉发网不接受广告合作,不接受链接交换,相关邮件一律不回!



选股最新文章列表

















相关文章列表


昨日热门文章

本周热门文章

本月热门文章

股票标签云


炒股知识大全