【日周月均线同时显示】实战性很强的均线共振主图(非引用周期函数 通达信 源码)


日线上实现跨周期显示“周均线”和“月均线”,不是市面上引用week和month函数的写法,手机通达信也可以使用。

关于日、周、月均线的共振,或许真的“学”会了,但“看”废了!
是否有疑惑:每次切换周期,看到同时金叉共振,但总是已经成为过去?
是否有想过:在日线上,周线和月线是如何金叉的?日线上哪几根K线起到了作用?

通过本人的日周月均线指标,可以很清晰的看到以前没发现的关键点。

本指标为主图,设置了5、10、20三种均线,白线为5(日周月),黄线为10(日周月),洋红线为20(日周月),都帮大家在后面用文字标记出来。


随便找了个股,大家能发现均线共振的点吗?
下载指标后,大家可以留言,来说说自己对日月周均线共振的理解,本贴就做抛砖引玉了。





简单的说一下基础使用方法:

看图说话:
1、上图为周线级别,我们看到3月26日这根周K线,发生了周5日与周10日金叉。
2、上图为周线级别,4月23日这根周K线,发生周5日上穿周20日,并且整根K线穿三线。(忘记画框框了)


1、上图为日线级别,利用日周月均线同图我们看到:3月22日-3月26日这周的五根K线,实际周线看到的金叉,在3月22日就已经金叉。
2、同样的,4月19日-4月23日这周的五根K线,实际周线看到的穿三线发生在4月21日,5日金叉20日发生在4月22日。

再啰嗦几句如何选股的话题。
首先,选股在任何情况下,只是对历史的客观回溯未来的主观判断,是一种对模型可能性高低的选择,而不是对股票本身的选择。
记住以上这句话,这句话是任何选股条件的前提,简述分解:

1、模型:
既然是模型,就必须有三点:起点!过程!终点!这三点缺一不可。很多人写选股习惯一叶障目,拼命写一个点,恨不得把所有条件都加在一个点上。
2、历史:
既然是历史,就必须有历史存在的意义,历史即代表过程,即代表模型可能性高低。如果没有过程,写一个点有什么用呢?
3、未来:
既然是未来,那就都是人为干预,所以不要去随意判断一个选股信号的好坏。你能做的只有优化、待定或抛弃。

看图说话:

文字能力和作图能力有限,想到哪里写到哪里,就这么着吧,能看懂就行,看不懂的留言讨论吧。

记住模型必须包含:起始点、建仓区间、信号动作点!

源码

DRAWKLINE(H,O,L,C);


日05:MA(C,5)*日五,COLORWHITE;

日10:MA(C,10)*日十,COLORYELLOW;

日20:MA(C,20)*日廿,COLORMAGENTA;



星期:=WEEKDAY,NODRAW;

日1:=DATETODAY(DATE);

上市日:=REF(DATE,TOTALBARSCOUNT-CURRBARSCOUNT);


自然日:=日1-DATETODAY(上市日)+1;

ZB:=(自然日-REF(自然日,1))!=星期-REF(星期,1) OR TOTALBARSCOUNT-CURRBARSCOUNT=0;

本周第几天:=BARSLAST(ZB)+1;

周MA1:=REF(C,本周第几天);

周MA2:=REF(周MA1,本周第几天);

周MA3:=REF(周MA2,本周第几天);

周MA4:=REF(周MA3,本周第几天);

周MA5:=REF(周MA4,本周第几天);

周MA6:=REF(周MA5,本周第几天);

周MA7:=REF(周MA6,本周第几天);

周MA8:=REF(周MA7,本周第几天);

周MA9:=REF(周MA8,本周第几天);

周MA10:=REF(周MA9,本周第几天);

周MA11:=REF(周MA10,本周第几天);

周MA12:=REF(周MA11,本周第几天);

周MA13:=REF(周MA12,本周第几天);

周MA14:=REF(周MA13,本周第几天);

周MA15:=REF(周MA14,本周第几天);

周MA16:=REF(周MA15,本周第几天);

周MA17:=REF(周MA16,本周第几天);

周MA18:=REF(周MA17,本周第几天);

周MA19:=REF(周MA18,本周第几天);

周05:(C+周MA1+周MA2+周MA3+周MA4)/5*周五,COLORWHITE,DOTLINE;

周10:(C+周MA1+周MA2+周MA3+周MA4+周MA5+周MA6+周MA7+周MA8+周MA9)/10*周十,COLORYELLOW,DOTLINE;

周20:(C+周MA1+周MA2+周MA3+周MA4+周MA5+周MA6+周MA7+周MA8+周MA9+周MA10+周MA11+周MA12+周MA13+周MA14+周MA15+周MA16+周MA17+周MA18+周MA19)/20*周廿,COLORMAGENTA,DOTLINE;

DRAWTEXT(ISLASTBAR,周05,' 周5'),COLORWHITE;

DRAWTEXT(ISLASTBAR,周10,' 周10'),COLORYELLOW;

DRAWTEXT(ISLASTBAR,周20,' 周20'),COLORMAGENTA;



年:=YEAR;

月:=MONTH;

本月第几天:=BARSLAST(年*100+月!=REF(年*100+月,1))+1;

月MA1:=REF(C,本月第几天);

月MA2:=REF(月MA1,本月第几天);

月MA3:=REF(月MA2,本月第几天);

月MA4:=REF(月MA3,本月第几天);

月MA5:=REF(月MA4,本月第几天);

月MA6:=REF(月MA5,本月第几天);

月MA7:=REF(月MA6,本月第几天);

月MA8:=REF(月MA7,本月第几天);

月MA9:=REF(月MA8,本月第几天);

月MA10:=REF(月MA9,本月第几天);

月MA11:=REF(月MA1,本月第几天);

月MA12:=REF(月MA1,本月第几天);

月MA13:=REF(月MA1,本月第几天);

月MA14:=REF(月MA1,本月第几天);

月MA15:=REF(月MA1,本月第几天);

月MA16:=REF(月MA1,本月第几天);

月MA17:=REF(月MA1,本月第几天);

月MA18:=REF(月MA1,本月第几天);

月MA19:=REF(月MA1,本月第几天);

月05:(C+月MA1+月MA2+月MA3+月MA4)/5*月五,COLORWHITE,DOTLINE;

月10:(C+月MA1+月MA2+月MA3+月MA4+月MA5+月MA6+月MA7+月MA8+月MA9)/10*月十,COLORYELLOW,DOTLINE;

月20:(C+月MA1+月MA2+月MA3+月MA4+月MA5+月MA6+月MA7+月MA8+月MA9+月MA10+月MA11+月MA12+月MA13+月MA14+月MA15+月MA16+月MA17+月MA18+月MA19)/20*月廿,COLORMAGENTA,DOTLINE;

DRAWTEXT(ISLASTBAR,月05,' 月5'),COLORWHITE;

DRAWTEXT(ISLASTBAR,月10,' 月10'),COLORYELLOW;

DRAWTEXT(ISLASTBAR,月20,' 月20'),COLORMAGENTA;




标签 REF本周均线选股信号

声明:
1. 版权归原作者“通达信指标爱好者”所有, 本文转载目的在于 股票财经 爱好者个人学习使用,并不代表吉发网赞同其观点和对其真实性负责。如有侵权行为,请联系站长(webmaster@666888.net.cn),站长会尽最大努力及时删除。
2. 吉发网不提供在线交流(评论)功能,如喜欢作者的文章请点击 关注作者 扫描二维码关注"通达信指标爱好者"后,与作者交流留言。
3. 如文章出现QQ号、QQ群、微信号、微信群,请仔细甄别,不要轻信所谓NB的战法、NB的讲师、股票推荐、不收任何费用、万人建仓等蛊惑性描述,如遭到财产损失,不要犹豫立即报警!立即报警!立即报警!
4. 欢迎推荐或自荐优秀股市财经金融公众号加入吉发网, 既可以涨粉,又能帮助股票财经爱好者学习成长,多有意义啊^_^。
5. 吉发网不接受广告合作,不接受链接交换,相关邮件一律不回!



技术指标最新文章列表

















相关文章列表


昨日热门文章

本周热门文章

本月热门文章

股票标签云


炒股知识大全