通达信指标公式源码多背离主图指标



做价值的传播者,路同行,一起成长

问题怎样才能每天都收到这类文章!

答案只需点击上方《通达信公式指标


均:=(3*C+H+L+O)/6;


短线:(8*均+7*REF(均,1)+6*REF(均,2)+5*REF(均,3)+4*REF(均,4)+3*REF(均,5)+2*REF(均,6)+REF(均,7))/36;


中线:(LLV(短线,3)+LLV(短线,5)+LLV(短线,8))/3;



C1:=BARSLAST(REF(CROSS("MACD.DEA"(12,26,9),"MACD.DIF"(12,26,9)),1));


D1:=REF(C,C1+1)<C AND REF("MACD.DIF"(12,26,9),C1+1)>"MACD.DIF"(12,26,9) AND CROSS("MACD.DEA"(12,26,9),"MACD.DIF"(12,26,9));


顶MACD:DRAWTEXT(FILTER(D1>0,5),HIGH*1.02,'↓'),COLOR00FF00;


DRAWTEXT(FILTER(D1>0,5),HIGH*1.04,'MACD顶'),COLORRED;


C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));


D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));


顶KDJ:DRAWTEXT(FILTER(D2>0,5),HIGH*1.02,'↓'),COLOR00FF00;

DRAWTEXT(FILTER(D2>0,5),HIGH*1.04,'KDJ顶'),COLORF00FF0;


C3:=BARSLAST(REF(CROSS("RSI.RSI2"(8,55,55),"RSI.RSI1"(8,55,55)),1));


D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(8,55,55),C3+1)>"RSI.RSI1"(8,55,55) AND CROSS("RSI.RSI2"(8,55,55),"RSI.RSI1"(8,55,55));


顶RSI:DRAWTEXT(FILTER(D3>0,5),HIGH*1.02,'↓'),COLOR00FF00;


DRAWTEXT(FILTER(D3>0,5),HIGH*1.04,'RSI顶'),COLORYELLOW;


C4:=BARSLAST(REF(CROSS("DMI.MDI"(14,6),"DMI.PDI"(14,6)),1));


D4:=REF(C,C4+1)<C AND REF("DMI.PDI"(14,6),C4+1)>"DMI.PDI"(14,6) AND CROSS("DMI.MDI"(14,6),"DMI.PDI"(14,6));


顶DMI:DRAWTEXT(FILTER(D4>0,5),HIGH*1.02,'↓'),COLOR00FF00;


DRAWTEXT(FILTER(D4>0,5),HIGH*1.04,'DMI顶'),COLORF0F000;


{底背离}


A1:=BARSLAST(REF(CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9)),1));


B1:=REF(C,A1+1)>C AND REF("MACD.DIF"(12,26,9),A1+1)<"MACD.DIF"(12,26,9) AND CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9));


底MACD:DRAWTEXT(FILTER(B1>0,5),LOW,'1'),COLORYELLOW;


DRAWTEXT(FILTER(B1>0,5),LOW*0.98,'MACD底'),COLOR00FF00;


A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));


B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));


底KDJ:DRAWTEXT(FILTER(B2>0,5),LOW,'↑'),COLORYELLOW;

DRAWTEXT(FILTER(B2>0,5),LOW*0.98,'KDJ底'),COLORRED;


A3:=BARSLAST(REF(CROSS("RSI.RSI1"(8,55,55),"RSI.RSI2"(8,55,55)),1));


B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(8,55,55),A3+1)<"RSI.RSI1"(8,55,55) AND CROSS("RSI.RSI1"(8,55,55),"RSI.RSI2"(8,55,55));


底RSI:DRAWTEXT(FILTER(B3>0,5),LOW,'↑'),COLORYELLOW;


DRAWTEXT(FILTER(B3>0,5),LOW*0.98,'RSI底'),COLORF0F000;


A4:=BARSLAST(REF(CROSS("DMI.PDI"(14,6),"DMI.MDI"(14,6)),1));


B4:=REF(C,A4+1)>C AND REF("DMI.PDI"(14,6),A4+1)<"DMI.PDI"(14,6) AND CROSS("DMI.PDI"(14,6),"DMI.MDI"(14,6));


底DMI:DRAWTEXT(FILTER(B4>0,5),LOW,'↑'),COLORYELLOW;


DRAWTEXT(FILTER(B4>0,5),LOW*0.98,'DMI底'),COLORF00FF0;

风险提示:本指标公式仅作为知识分享,不构成任何投资建议,不作投资依据。


=====================

提供服务如下:

1、转换 --- 根据客户提供的电脑板或者手机版技术指标源码,转换成自己的手机软件使用

2、编写 --- 按照客户定制指标时“提供的编写要求”,制作技术指标

3、修改 --- 按照客户“提供的修改要求”,修改技术指标


点击阅读原文查阅更多经典指标


标签 REF指标BARSLAST提供FILTER

声明:
1. 版权归原作者“通达信公式指标”所有, 本文转载目的在于 股票财经 爱好者个人学习使用,并不代表吉发网赞同其观点和对其真实性负责。如有侵权行为,请联系站长(webmaster@666888.net.cn),站长会尽最大努力及时删除。
2. 吉发网不提供在线交流(评论)功能,如喜欢作者的文章请点击 关注作者 扫描二维码关注"通达信公式指标"后,与作者交流留言。
3. 如文章出现QQ号、QQ群、微信号、微信群,请仔细甄别,不要轻信所谓NB的战法、NB的讲师、股票推荐、不收任何费用、万人建仓等蛊惑性描述,如遭到财产损失,不要犹豫立即报警!立即报警!立即报警!
4. 欢迎推荐或自荐优秀股市财经金融公众号加入吉发网, 既可以涨粉,又能帮助股票财经爱好者学习成长,多有意义啊^_^。
5. 吉发网不接受广告合作,不接受链接交换,相关邮件一律不回!



技术指标最新文章列表

















相关文章列表


昨日热门文章

本周热门文章

本月热门文章

股票标签云


炒股知识大全