短线擒牛主图(指标 副图/选股 通达信 贴图)


 

祝大家投资顺利 希望大家可以参考。再次提醒,没有完美的指标也没有万能的指标,即便是指标做的再完美也都有出现瑕疵的时候。

指标是辅助,是参考!

指标做的再完美也不如一个消息 

但是,个股犹如四季轮回,有涨有跌,K线是资金走过留下的痕迹,追寻这样的痕迹能不能得到回报?答案是肯定的。有许许多多的高手就是这样不看基本面不看消息面,纯技术手法驰骋股市。


短线擒牛主图(指标 副图/选股 通达信 贴图)

主图


N:=150;M:=3;

高:=CONST(REF(HHV(H,N),M)); 

低:=CONST(REF(LLV(L,N),M));

色彩峰:=高-低;

STICKLINE(色彩峰>0,低,低+色彩峰*1.05,10,0),COLORFF0000;

STICKLINE(色彩峰>0,低,低+色彩峰*0.9,10,0),COLORFF1111;

STICKLINE(色彩峰>0,低,低+色彩峰*0.85,10,0),COLORFF2222;

STICKLINE(色彩峰>0,低,低+色彩峰*0.8,10,0),COLORFF3333;

STICKLINE(色彩峰>0,低,低+色彩峰*0.75,10,0),COLORFF4444;

STICKLINE(色彩峰>0,低,低+色彩峰*0.7,10,0),COLORFF5555;

STICKLINE(色彩峰>0,低,低+色彩峰*0.65,10,0),COLORFF6666;

STICKLINE(色彩峰>0,低,低+色彩峰*0.6,10,0),COLORFF7777;

STICKLINE(色彩峰>0,低,低+色彩峰*0.55,10,0),COLORFF8888;

STICKLINE(色彩峰>0,低,低+色彩峰*0.5,10,0),COLORFF9999;

STICKLINE(色彩峰>0,低,低+色彩峰*0.45,10,0),COLORFFAAAA;

STICKLINE(色彩峰>0,低,低+色彩峰*0.4,10,0),COLORFFBBBB;

STICKLINE(色彩峰>0,低,低+色彩峰*0.35,10,0),COLORFFCCCC;

STICKLINE(色彩峰>0,低,低+色彩峰*0.3,10,0),COLORFFDDDD;

STICKLINE(色彩峰>0,低,低+色彩峰*0.25,10,0),COLORFFEEEE;

高1:=REF(HHV(H,120),3);

低1:=REF(LLV(L,120),3);

H1:=高1-(高1-低1)*0.191; 

H2:=高1-(高1-低1)*0.382; 

H3:=高1-(高1-低1)*0.5; 

H4:=高1-(高1-低1)*0.618; 

H5:=高1-(高1-低1)*0.809;

突破:=REF(EMA(C,14),1);

A1X:=(EMA(C,10)-突破)/突破*100;

基准:=IF(A1X>=0,REF(EMA(C,10),BARSLAST(CROSS(A1X,0))+1),REF(EMA(C,10),BARSLAST(CROSS(0,A1X))+1));

STICKLINE(A1X>=0,基准,突破,10,0),COLOR000099;

STICKLINE(A1X<0,基准,突破,10,0),COLOR320000;

西:=(3*CLOSE+OPEN+LOW+HIGH)/6;

电:(20*西+19*REF(西,1)+18*REF(西,2)+17*REF

(西,3)+16*REF(西,4)+15*REF(西,5)+14*REF(西,6)

+13*REF(西,7)+12*REF(西,8)+11*REF(西,9)+10*REF

(西,10)+9*REF(西,11)+8*REF(西,12)

+7*REF(西,13)+6*REF(西,14)+5*REF(西,15)+4*REF

(西,16)+3*REF(西,17)+2*REF(西,18)+

REF(西,20))/210,COLORYELLOW;

点:MA(电,5),COLORRED;

DRAWBAND(电,RGB(223,0,41),点,RGB(91,189,43));DRAWKLINE(H,O,L,C);

ZKP:=IF(C>REF(C,1),REF(C,1),DRAWNULL);

ZSP:=IF(C>REF(C,1),C,DRAWNULL);

DKP:=IF(C<=REF(C,1),REF(C,1),DRAWNULL);

DSP:=IF(C<=REF(C,1),C,DRAWNULL);

DRAWKLINE(H,DKP,L,DSP);

STICKLINE(C<=REF(C,1),DKP,DSP,3.05,0),COLORBLUE;

STICKLINE(C<=REF(C,1),DKP,DSP,2.2,0),COLORFF7700;

STICKLINE(C<=REF(C,1),DKP,DSP,1.5,0),COLORFF9900;

STICKLINE(C<=REF(C,1),DKP,DSP,0.5,0),COLORFFBB00;

DRAWKLINE(H,ZKP,L,ZSP);

STICKLINE(C>REF(C,1),ZKP,ZSP,3.05,0),COLOR000099;

STICKLINE(C>REF(C,1),ZKP,ZSP,2.2,0),COLOR0000CC;

STICKLINE(C>REF(C,1),ZKP,ZSP,1.5,0),COLOR0000FF; 

STICKLINE(C>REF(C,1),ZKP,ZSP,0.5,0),COLORCC66FF;

STICKLINE(V/REF(V,1)>2 AND CLOSE>=OPEN,ZKP,ZSP,3,0),COLOR0055FF;

STICKLINE((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,3,0),COLORYELLOW;

STICKLINE((REF(C,1)-C)*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,3,0),COLORGREEN;

G:=IF(HIGH=HHV(HIGH,3),1,0);

D:=IF(LOW=LLV(LOW,3),1,0);

S:=IF(REF(G,2)=1 AND REF(G,1)=0 AND G=0,REF(HIGH,2),REF(HIGH,2+BARSLAST(REF(G,2)=1 AND REF(G,1)=0 AND G=0)));

X:=IF(REF(D,2)=1 AND REF(D,1)=0 AND D=0,REF(LOW,2),REF(LOW,2+BARSLAST(REF(D,2)=1 AND REF(D,1)=0 AND D=0)));

K1:=IF(HIGH>=MA(CLOSE,1),S,REF(S,BARSLAST(HIGH>MA(CLOSE,1))));

K2:=IF(LOW<=MA(CLOSE,1),X,REF(X,BARSLAST(LOW<=MA(CLOSE,1))));

C1:=REF(CLOSE,1)<=K1 AND CLOSE>K1;

C2:=REF(CLOSE,1)>=K2 AND CLOSE<K2;

K3:=BARSLAST(C1);

K4:=BARSLAST(C2);

高点:IF(K3>K4,K1,DRAWNULL),LINETHICK2,COLORYELLOW;

升高点:=HIGH<REF(HIGH,1) AND REF(HIGH,1)>REF(HIGH,2);

KK:=BARSLAST(升高点);

升高:REF(HIGH,KK+1),LINETHICK0;

IF(CLOSE,升高,DRAWNULL),,COLORRED;

末升低点:=CROSS(CLOSE,升高) AND (CLOSE-REF(升高,0))/REF(升高,0)>=0.03 OR VOL>REF(VOL,1) AND CLOSE>OPEN AND CLOSE>1*REF((CLOSE+OPEN)/2,1) AND LOW>REF(LOW,1) AND REF(LOW,1)<REF(LOW,2) OR REF(VOL,1)>REF(VOL,2) AND CLOSE>OPEN AND CLOSE>REF(CLOSE,1)*1.04 AND (REF(CLOSE,1)-REF(CLOSE,2))/REF(CLOSE,2)>=0.03;

TY:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=0.095 OR 末升低点;

SJ:=BARSLAST(TY);

TJ1:=VOL<REF(VOL,1) AND REF(VOL,1)>REF(VOL,2) OR CLOSE>REF(CLOSE,1) AND REF(CLOSE,1)>REF(CLOSE,2) AND REF(CLOSE,2)>REF(CLOSE,3);

SJ1:=BARSLAST(TJ1);

XDJL:=SJ;

PPPP:=BARSLAST(XDJL);

止损:REF(LOW,SJ1+1),COLORGREEN;

止盈:REF(LOW,SJ+1),COLORYELLOW;

IF(CLOSE>=止损,止损,DRAWNULL),LINETHICK2,COLORGREEN;

IF(CLOSE<REF(止损,1) AND CLOSE<=止损,止损,DRAWNULL),LINETHICK2,COLORGREEN;

线:=MA(C,160);

割肉线:REFDATE(线,DATE),COLOR5C3317,LINETHICK1,POINTDOT;

DRAWTEXT(ISLASTBAR,割肉线,'割肉线'),COLOR5C3317;

A:=SUMBARS(V,CAPITAL*1);{累计换手=100%的周期}

A1:=SUM(COST(10),A)/A;{在A周期里获利10%的平均价}

A2:=SUM(COST(20),A)/A;{在A周期里获利20%的平均价}

A3:=SUM(COST(30),A)/A;{在A周期里获利30%的平均价}

A4:=SUM(COST(40),A)/A;{在A周期里获利40%的平均价}

A5:=SUM(COST(50),A)/A;{在A周期里获利50%的平均价}

成本线:(5*A1+4*A2+3*A3+2*A4+A5)/15,NODRAW,COLOR0055FF;

STICKLINE(ISLASTBAR ,成本线,成本线,30,0),LINETHICK2,COLOR0055FF;

DRAWTEXT(ISLASTBAR,成本线,'           成本线'),COLOR0055FF;

DRAWICON(A1X>=0 AND REF(A1X,1)<0,L*0.96,1);

DRAWICON(A1X<0 AND REF(A1X,1)>=0,H*1.02,2);

DRAWTEXT_FIX(ISLASTBAR,0.00,0.30,0,'★ ★粉丝专用★★'),COLORRED;




副图选股一体

W1:=C=HHV(C,20);

W2:=BARSLAST(W1);

W3:=IF(W2>0,REF(C,W2),REF(C,W2));

W4:=CROSS(C,REF(W3,1));

短线擒牛:W4 AND COUNT(W4,5)=1;


各种股票资料学习指标 淘股吧理想论坛大咖观点技术直播等团购微信,有兴趣的朋友可添加微信  

主号  gupiaoxuexi2020   

备用号 gpxx68




标签 REFBARSLAST指标CLOSESUM

声明:
1. 版权归原作者“通达信指标爱好者”所有, 本文转载目的在于 股票财经 爱好者个人学习使用,并不代表吉发网赞同其观点和对其真实性负责。如有侵权行为,请联系站长(webmaster@666888.net.cn),站长会尽最大努力及时删除。
2. 吉发网不提供在线交流(评论)功能,如喜欢作者的文章请点击 关注作者 扫描二维码关注"通达信指标爱好者"后,与作者交流留言。
3. 如文章出现QQ号、QQ群、微信号、微信群,请仔细甄别,不要轻信所谓NB的战法、NB的讲师、股票推荐、不收任何费用、万人建仓等蛊惑性描述,如遭到财产损失,不要犹豫立即报警!立即报警!立即报警!
4. 欢迎推荐或自荐优秀股市财经金融公众号加入吉发网, 既可以涨粉,又能帮助股票财经爱好者学习成长,多有意义啊^_^。
5. 吉发网不接受广告合作,不接受链接交换,相关邮件一律不回!



选股最新文章列表

















相关文章列表


昨日热门文章

本周热门文章

本月热门文章

股票标签云


炒股知识大全