极品短牛(源码 主图 副图选股通达信 贴图)


祝大家投资顺利,一起面对行情 无数次实践证明做波段才是盈利王道  希望大家可以参考。再次提醒,没有完美的指标也没有万能的指标,即便是指标做的再完美也都有出现瑕疵的时候。

指标是辅助,是参考!

指标做的再完美也不如一个消息 

但是,个股犹如四季轮回,有涨有跌,K线是资金走过留下的痕迹,追寻这样的痕迹能不能得到回报?答案是肯定的。有许许多多的高手就是这样不看基本面不看消息面,纯技术手法驰骋股市。


极品短牛(源码 主图 副图选股通达信 贴图)



主图

AA1:LLV((2*CLOSE+HIGH+LOW)/4,21),COLORRED,LINETHICK2;

A2:HHV((2*CLOSE+HIGH+LOW)/4,21),COLORFF0080,LINETHICK2;

X_1:=YEAR;

X_2:=MONTH;

X_3:=WEEKDAY;

X_4:=DATETODAY(DATE);

X_5:=REF(DATE,TOTALBARSCOUNT-CURRBARSCOUNT);

X_6:=X_4-DATETODAY(X_5)+1;

X_7:=X_6-REF(X_6,1)!=X_3-REF(X_3,1) OR TOTALBARSCOUNT-CURRBARSCOUNT=0;

X_8:=BARSLAST(X_7)+1;

X_9:=BARSLAST(X_1*100+X_2!=REF(X_1*100+X_2,1))+1;

X_10:=REF(CLOSE,X_8);

X_11:=REF(X_10,X_8);

X_12:=REF(X_11,X_8);

X_13:=REF(X_12,X_8);

X_14:=REF(X_13,X_8);

X_15:=REF(X_14,X_8);

X_16:=REF(X_15,X_8);

X_17:=REF(X_16,X_8);

X_18:=REF(X_17,X_8);

X_19:=(CLOSE+X_10+X_11+X_12+X_13+X_14+X_15+X_16+X_17+X_18)/10;

闪亮登场:REFDATE(X_19,DATE),DOTLINE,COLORYELLOW;

DRAWTEXT(ISLASTBAR,闪亮登场,66),COLORYELLOW;

DRAWKLINE(HIGH,IF(CLOSE<=REF(CLOSE,1),REF(CLOSE,1),DRAWNULL),LOW,IF(CLOSE<=REF(CLOSE,1),CLOSE,DRAWNULL));

STICKLINE(CLOSE<=REF(CLOSE,1),IF(CLOSE<=REF(CLOSE,1),REF(CLOSE,1),DRAWNULL),IF(CLOSE<=REF(CLOSE,1),CLOSE,DRAWNULL),3.05,0),COLORBLUE;

STICKLINE(CLOSE<=REF(CLOSE,1),IF(CLOSE<=REF(CLOSE,1),REF(CLOSE,1),DRAWNULL),IF(CLOSE<=REF(CLOSE,1),CLOSE,DRAWNULL),2.2,0),COLORFF7700;

STICKLINE(CLOSE<=REF(CLOSE,1),IF(CLOSE<=REF(CLOSE,1),REF(CLOSE,1),DRAWNULL),IF(CLOSE<=REF(CLOSE,1),CLOSE,DRAWNULL),1.5,0),COLORFF9900;

STICKLINE(CLOSE<=REF(CLOSE,1),IF(CLOSE<=REF(CLOSE,1),REF(CLOSE,1),DRAWNULL),IF(CLOSE<=REF(CLOSE,1),CLOSE,DRAWNULL),0.5,0),COLORFFBB00;

DRAWKLINE(HIGH,IF(CLOSE>REF(CLOSE,1),REF(CLOSE,1),DRAWNULL),LOW,IF(CLOSE>REF(CLOSE,1),CLOSE,DRAWNULL));

STICKLINE(CLOSE>REF(CLOSE,1),IF(CLOSE>REF(CLOSE,1),REF(CLOSE,1),DRAWNULL),IF(CLOSE>REF(CLOSE,1),CLOSE,DRAWNULL),3.05,0),COLOR000099;

STICKLINE(CLOSE>REF(CLOSE,1),IF(CLOSE>REF(CLOSE,1),REF(CLOSE,1),DRAWNULL),IF(CLOSE>REF(CLOSE,1),CLOSE,DRAWNULL),2.2,0),COLOR0000CC;

STICKLINE(CLOSE>REF(CLOSE,1),IF(CLOSE>REF(CLOSE,1),REF(CLOSE,1),DRAWNULL),IF(CLOSE>REF(CLOSE,1),CLOSE,DRAWNULL),1.5,0),COLORRED;

STICKLINE(CLOSE>REF(CLOSE,1),IF(CLOSE>REF(CLOSE,1),REF(CLOSE,1),DRAWNULL),IF(CLOSE>REF(CLOSE,1),CLOSE,DRAWNULL),0.5,0),COLORCC66FF;

STICKLINE(VOL/REF(VOL,1)>2 AND CLOSE>=OPEN,IF(CLOSE>REF(CLOSE,1),REF(CLOSE,1),DRAWNULL),IF(CLOSE>REF(CLOSE,1),CLOSE,DRAWNULL),1,0),COLORYELLOW;

 


副图

ZEROS:0,NODRAW;


RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;


K:=SMA(RSV,3,1);


D:=SMA(K,3,1);


J:=3*K-2*D;


VARV:=(2*C+H+L)/4;


VARU:=LLV(LOW,30);


VARA1:=HHV(HIGH,30);


B:=EMA((VARV-VARU)/(VARA1-VARU)*100,8);


B1:=EMA(B,5);


STICKLINE(B-B1>0,B,B1,8,1),COLORRED;


STICKLINE(B-B1<0,B,B1,8,1),COLOR00FF00;


多:=B-B1>0;


空:=B-B1<0;


转空:=空 AND REF(多,1);


转多:多 AND REF(空,1),NODRAW;


转多期:=COUNT(转多,5);


PASTDAYS:=5;


DRAWICON(转空,MAX(B,B1),'SELL');


DRAWTEXT(转空,MAX(B,B1)+25,'卖');


LC:=REF(CLOSE,1);


RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;


低吸:IF(CROSS(RSI,11),70,0),COLORWHITE,POINTDOT;


STICKLINE(低吸,MIN(B,B1),0,4,0),COLORWHITE;


VAR7:=EMA(AMOUNT/VOL/100,3);


VAR8:=EMA(VAR7,88);


VAR9:=EMA(VAR7,88)*0.85;


VARA:=VAR9*0.87;


VARB:=LOW<VARA AND CLOSE>REF(CLOSE,1)*1.02;


STICKLINE(FILTER(VARB,6),MIN(B,B1),0,4,0),COLORFF00FF;


坚决买进:IF(FILTER(VARB,6),65,0),COLORFF00FF,POINTDOT;


VARF:=(2*CLOSE+HIGH+LOW)/4;


VA4:=LLV(LOW,34);


VA5:=HHV(HIGH,34);


VA6:=EMA((VARF-VA4)/(VA5-VA4)*100,6);


VA7:=EMA(0.667*REF(VA6,1)+0.333*VA6,4);


出击:IF(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(VA6>VA7,3) AND REF(LOW,1)=LLV(LOW,120) AND


CLOSE>OPEN,1,0),60,0),COLORYELLOW,POINTDOT;


STICKLINE(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(VA6>VA7,3) AND


REF(LOW,1)=LLV(LOW,120) AND CLOSE>OPEN,1,0),MIN(B,B1),0,4,0),COLORFF00FF;


A:=(3*CLOSE+LOW+OPEN+HIGH)/6;


D1:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)


+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)



 

+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+


REF(A,20))/211;


D2:=EMA(D1,2);


D3:=EMA(D2,2);


K1:=EMA(D3,2);


波段买入:IF(CROSS(D1,K1) AND 多>0,MIN(B,B1),0),COLOR0099FF,POINTDOT;


STICKLINE(波段买入,MIN(B,B1),0,4,0),COLOR0099FF;


多方趋势:=7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)


-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)


-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)


,3,1),2,1);


天线:=78.89;


STICKLINE(CROSS(天线,多方趋势),90,95,6,0),COLOR00FF00;


STICKLINE(B>0 AND B-B1>=0,79,80,6,0),COLORRED;


STICKLINE(B>0 AND B-B1<0,79,80,6,0),COLOR00FF00;


STICKLINE(B>0 AND B-B1>=0,49,50,6,0),COLORRED;


STICKLINE(B>0 AND B-B1<0,49,50,6,0),COLORFF8899;


STICKLINE(B>0 AND B-B1>=0,19,20,6,0),COLORRED;


STICKLINE(B>0 AND B-B1<0,19,20,6,0),COLOR00FF00;


STICKLINE(B-B1>0,B,B1,8,1),COLORRED;


STICKLINE(B-B1<0,B,B1,8,1),COLOR00FF00;


地量:DRAWTEXT(CROSS(0.9,1/VOL*1000>0.01 AND J<0),L*1,'地量'),COLOR00FFFF;


STICKLINE(地量>0,0,30,2,0),COLOR008888;


STICKLINE(地量>0,0,30,1.5,0),COLOR00AAAA;


STICKLINE(地量>0,0,30,0.8,0),COLOR00DDDD;


STICKLINE(地量>0,0,30,0.3,0),COLOR00FFFF;


VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;


DRAWICON(CROSS(82,VARR1),10,15);


VAR10:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);


VAR11:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);



 

VAR12:=VAR10<REF(VAR11,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);


主力进场:VAR12 AND COUNT(VAR12,30)=1,NODRAW;


DRAWTEXT(主力进场,MAX(B,B1)+30,'主力进场!');


主力进场期:COUNT(主力进场,PASTDAYS),NODRAW;


DIFF:=EMA(C,12)-EMA(C,26),COLORWHITE;


DEA:=EMA(DIFF,8),COLORFFAA00;


MACD:=2*(DIFF-DEA);


DIFF上穿0轴:=CROSS(DIFF,0),NODRAW;


MACD金叉:=CROSS(DIFF,DEA),NODRAW;


MACD金叉期:=COUNT(MACD金叉,PASTDAYS),NODRAW;


MACD势增:=MACD>REF(MACD,1);


N:=9;M1:=3;M2:=3;


KDJ势增:J>REF(J,1),NODRAW;


高安全区:=0,COLORRED;


安全区:=20,COLORCYAN;


风险区:=100,COLORGREEN;


KDJ金叉:=CROSS(J,K),NODRAW;


KDJ死叉:=CROSS(K,J),NODRAW;


KDJ买点:=KDJ金叉 ;


KDJ卖点:=KDJ死叉;


KDJ买点期:=COUNT(KDJ买点,PASTDAYS),NODRAW;


通:=MA(C,21);


低吸期:=COUNT(低吸,PASTDAYS);


出击期:COUNT(出击,PASTDAYS);


坚决买进期:COUNT(坚决买进,PASTDAYS);


波段买入期:COUNT(波段买入,PASTDAYS);


转多买点:(转多期) AND (KDJ金叉 OR MACD金叉),NODRAW;


最佳买点:(多>0) AND (主力进场期 OR 出击期 OR 坚决买进期 OR 波段买入期) AND (KDJ金叉 OR MACD金叉),NODRAW;


波段买点:((主力进场 OR 出击 OR 坚决买进 OR 波段买入 OR 转多) AND (KDJ势增 OR MACD势增 )) OR 最佳买点 ,NODRAW;


DRAWICON(低吸,0,'BUY');


DRAWTEXT(低吸 AND 最佳买点<1,-16,'吸'),COLORWHITE;


DRAWICON(出击 AND 多,0,'BUY');


DRAWTEXT(出击  AND 多 AND 最佳买点<1,-16,'击'),COLORYELLOW;


DRAWICON(坚决买进  AND 多,0,'BUY');


DRAWTEXT(坚决买进  AND 多 AND 最佳买点<1,-16,'进'),COLORFF00FF;


DRAWICON(波段买入  AND 多,0,'BUY');


DRAWTEXT(波段买入  AND 多 AND 最佳买点<1,-16,'买'),COLOR0099FF;


DRAWICON(最佳买点,0,'BUY');


DRAWICON(最佳买点,-2,'BUY');


DRAWICON(最佳买点,-8,'BUY');


DRAWTEXT(最佳买点,-30,'佳'),COLORRED;


DRAWTEXT(主力进场 AND 最佳买点<1,-10,'潜'),COLORYELLOW;


DRAWICON(主力进场 AND 最佳买点<1,0,'BUY');


最佳买点期:COUNT(最佳买点,PASTDAYS),NODRAW;


STICKLINE(波段买点,0,MIN(B,B1)-0.2,8,0),COLOR000066;


STICKLINE(波段买点,0,MIN(B,B1)-0.2,7,0),COLOR000077;


STICKLINE(波段买点,0,MIN(B,B1)-0.2,6,0),COLOR000088;


STICKLINE(波段买点,0,MIN(B,B1)-0.2,5,0),COLOR000099;


STICKLINE(波段买点,0,MIN(B,B1)-0.2,4,0),COLOR0000AA;


STICKLINE(波段买点,0,MIN(B,B1)-0.2,3,0),COLOR0000BB;


STICKLINE(波段买点,0,MIN(B,B1)-0.2,2,0),COLOR0000CC;


STICKLINE(波段买点,0,MIN(B,B1)-0.2,1,0),COLOR0000DD;



副图选股一体(2)


AA1:=AMOUNT/VOL;

BB1:=L< AA1*0.9;

CC1:=(C-REF(C,1))/REF(C,1)*100> 1.2;

DD1:=L< MA(C,5)*0.921;

EE1:=VOL< MA(V,5)*1.5;

极品短牛:BB1 AND CC1 AND DD1 AND EE1;



各种股票资料学习指标 淘股吧理想论坛大咖观点技术直播等团购微信,有兴趣的朋友可添加微信  

主号  gupiaoxuexi2020   

备用号 gpxx68

 




标签 EMACLOSEREFB1CROSS

声明:
1. 版权归原作者“通达信指标爱好者”所有, 本文转载目的在于 股票财经 爱好者个人学习使用,并不代表吉发网赞同其观点和对其真实性负责。如有侵权行为,请联系站长(webmaster@666888.net.cn),站长会尽最大努力及时删除。
2. 吉发网不提供在线交流(评论)功能,如喜欢作者的文章请点击 关注作者 扫描二维码关注"通达信指标爱好者"后,与作者交流留言。
3. 如文章出现QQ号、QQ群、微信号、微信群,请仔细甄别,不要轻信所谓NB的战法、NB的讲师、股票推荐、不收任何费用、万人建仓等蛊惑性描述,如遭到财产损失,不要犹豫立即报警!立即报警!立即报警!
4. 欢迎推荐或自荐优秀股市财经金融公众号加入吉发网, 既可以涨粉,又能帮助股票财经爱好者学习成长,多有意义啊^_^。
5. 吉发网不接受广告合作,不接受链接交换,相关邮件一律不回!



选股最新文章列表

















相关文章列表


昨日热门文章

本周热门文章

本月热门文章

股票标签云


炒股知识大全